Page 1 of 1

Installing on MX-23 help needed - updated

Posted: Wed Nov 22, 2023 6:59 pm
by Brutus
I've tried installing using the ppa repository but I have uninstallable dependencies. So the easy way wont work.

I've tried building from source but get errors with unsupported calls in the code at the last stage....

Code: Select all

[  1%] Building CXX object src/CMakeFiles/guayadeque.dir/ui/aui/AuiNotebook.cpp.o
/home/john/Desktop/apps/guayadeque/src/ui/aui/AuiNotebook.cpp: In member function ‘virtual void Guayadeque::guAuiTabArt::DrawTab(wxDC&, wxWindow*, const wxAuiNotebookPage&, const wxRect&, int, wxRect*, wxRect*, int*)’:
/home/john/Desktop/apps/guayadeque/src/ui/aui/AuiNotebook.cpp:296:47: error: ‘class wxBitmapBundle’ has no member named ‘GetWidth’
  296 |         close_button_width = m_activeCloseBmp.GetWidth();
      |                                               ^~~~~~~~
/home/john/Desktop/apps/guayadeque/src/ui/aui/AuiNotebook.cpp:308:76: error: ‘const class wxBitmapBundle’ has no member named ‘GetHeight’
  308 |                       drawn_tab_yoff + (drawn_tab_height/2) - (page.bitmap.GetHeight()/2),
      |                                                                            ^~~~~~~~~
/home/john/Desktop/apps/guayadeque/src/ui/aui/AuiNotebook.cpp:311:51: error: ‘const class wxBitmapBundle’ has no member named ‘GetWidth’
  311 |         text_offset = bitmap_offset + page.bitmap.GetWidth();
      |                                                   ^~~~~~~~
/home/john/Desktop/apps/guayadeque/src/ui/aui/AuiNotebook.cpp:334:24: error: conversion from ‘wxBitmapBundle’ to non-scalar type ‘wxBitmap’ requested
  334 |         wxBitmap bmp = m_disabledCloseBmp;
      |                        ^~~~~~~~~~~~~~~~~~
/home/john/Desktop/apps/guayadeque/src/ui/aui/AuiNotebook.cpp:339:19: error: no match for ‘operator=’ (operand types are ‘wxBitmap’ and ‘wxBitmapBundle’)
  339 |             bmp = m_activeCloseBmp;
      |                   ^~~~~~~~~~~~~~~~
In file included from /usr/include/wx-3.2/wx/bitmap.h:318,
                 from /usr/include/wx-3.2/wx/generic/panelg.h:14,
                 from /usr/include/wx-3.2/wx/panel.h:69,
                 from /usr/include/wx-3.2/wx/wx.h:40,
                 from /home/john/Desktop/apps/guayadeque/src/misc/Utils.h:25,
                 from /home/john/Desktop/apps/guayadeque/src/ui/aui/AuiNotebook.h:25,
                 from /home/john/Desktop/apps/guayadeque/src/ui/aui/AuiNotebook.cpp:22:
/usr/include/wx-3.2/wx/gtk/bitmap.h:63:24: note: candidate: ‘wxBitmap& wxBitmap::operator=(const wxBitmap&)’
   63 | class WXDLLIMPEXP_CORE wxBitmap: public wxBitmapBase
      |                        ^~~~~~~~
/usr/include/wx-3.2/wx/gtk/bitmap.h:63:24: note:   no known conversion for argument 1 from ‘wxBitmapBundle’ to ‘const wxBitmap&’
make[2]: *** [src/CMakeFiles/guayadeque.dir/build.make:720: src/CMakeFiles/guayadeque.dir/ui/aui/AuiNotebook.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:698: src/CMakeFiles/guayadeque.dir/all] Error 2
make: *** [Makefile:136: all] Error 2
I'm open to any ideas on how to proceed ?

Does anyone have a debian bookworm appimage ?