It was working fine--

General discussions
Post Reply
xminusone
Posts: 8
Joined: Fri Jan 17, 2020 11:19 pm

It was working fine--

Post by xminusone »

--but the more updates I get for Kubuntu 20.04, the more problems I had, until now it's pretty much unusable. It crashes on a variety of inputs, but most definitely on searches. You know I love your program and this is practically breaking my pathetic little heart. Anyhow, here's the latest backtrace from today:

[START:

ASSERT INFO:
../include/wx/datetime.h(1740): assert "IsValid()" failed in GetTicks(): invalid wxDateTime

BACKTRACE:
[1] wxDateTime::Format(wxString const&, wxDateTime::TimeZone const&) const
[2] Guayadeque::guSoListBox::OnGetItemText(int, int) const
[3] Guayadeque::guListViewClient::DoDrawItem(wxDC&, wxRect const&, int, int) const
[4] Guayadeque::guListViewClient::OnDrawItem(wxDC&, wxRect const&, unsigned long) const
[5] Guayadeque::guListViewClient::OnPaint(wxPaintEvent&)
[6] wxEvtHandler::ProcessEventIfMatchesId(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&)
[7] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*)
[8] wxEvtHandler::TryHereOnly(wxEvent&)
[9] wxEvtHandler::ProcessEventLocally(wxEvent&)
[10] wxEvtHandler::ProcessEvent(wxEvent&)
[11] wxVarScrollHelperEvtHandler::ProcessEvent(wxEvent&)
[12] wxEvtHandler::SafelyProcessEvent(wxEvent&)
[13] wxWindow::GTKSendPaintEvents(_cairo*)
[14] g_closure_invoke
[15] g_signal_emit_valist
[16] g_signal_emit
[17] gtk_container_propagate_draw
[18] gtk_container_propagate_draw
[19] g_closure_invoke
[20] g_signal_emit_valist
[21] g_signal_emit
[22] gtk_container_propagate_draw
[23] gtk_container_propagate_draw
[24] g_closure_invoke
[25] g_signal_emit_valist
[26] g_signal_emit
[27] gtk_container_propagate_draw
[28] g_closure_invoke
[29] g_signal_emit_valist
[30] g_signal_emit
[31] gtk_container_propagate_draw
[32] g_closure_invoke
[33] g_signal_emit_valist
[34] g_signal_emit
[35] gtk_container_propagate_draw
[36] g_closure_invoke
[37] g_signal_emit_valist
[38] g_signal_emit
[39] gtk_container_propagate_draw
[40] g_closure_invoke
[41] g_signal_emit_valist
[42] g_signal_emit
[43] gtk_container_propagate_draw
[44] gtk_container_propagate_draw
[45] gtk_main_do_event
[46] g_signal_emit_valist
[47] g_signal_emit
[48] g_main_context_dispatch
[49] g_main_loop_run
[50] gtk_main
[51] wxGUIEventLoop::DoRun()
[52] wxEventLoopBase::Run()
[53] wxAppConsoleBase::MainLoop()
[54] wxEntry(int&, wchar_t**)
[55] main
[56] __libc_start_main
[57] _start

END]
--------------------------------------------------------------------------------------------------
If you find time to address this issue, anonbeat, well, what can I say? You already have my undying gratitude for fixing that font size issue I had a few years back.
xminusone
Posts: 8
Joined: Fri Jan 17, 2020 11:19 pm

Crash On Sorting By 'Added'

Post by xminusone »

For what it's worth, here's another backtrace from a Guayadeque crash. This time, it starts up and crashes when I sort to "newest' clicking on the "Added" column in the collection database.
------------------------------------------------------------------------------------------------------------------------------
[START:

ASSERT INFO:
../include/wx/datetime.h(1740): assert "IsValid()" failed in GetTicks(): invalid wxDateTime

BACKTRACE:
[1] wxDateTime::Format(wxString const&, wxDateTime::TimeZone const&) const
[2] Guayadeque::guSoListBox::OnGetItemText(int, int) const
[3] Guayadeque::guListViewClient::DoDrawItem(wxDC&, wxRect const&, int, int) const
[4] Guayadeque::guListViewClient::OnDrawItem(wxDC&, wxRect const&, unsigned long) const
[5] Guayadeque::guListViewClient::OnPaint(wxPaintEvent&)
[6] wxEvtHandler::ProcessEventIfMatchesId(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&)
[7] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*)
[8] wxEvtHandler::TryHereOnly(wxEvent&)
[9] wxEvtHandler::ProcessEventLocally(wxEvent&)
[10] wxEvtHandler::ProcessEvent(wxEvent&)
[11] wxVarScrollHelperEvtHandler::ProcessEvent(wxEvent&)
[12] wxEvtHandler::SafelyProcessEvent(wxEvent&)
[13] wxWindow::GTKSendPaintEvents(_cairo*)
[14] g_closure_invoke
[15] g_signal_emit_valist
[16] g_signal_emit
[17] gtk_container_propagate_draw
[18] gtk_container_propagate_draw
[19] g_closure_invoke
[20] g_signal_emit_valist
[21] g_signal_emit
[22] gtk_container_propagate_draw
[23] gtk_container_propagate_draw
[24] g_closure_invoke
[25] g_signal_emit_valist
[26] g_signal_emit
[27] gtk_container_propagate_draw
[28] g_closure_invoke
[29] g_signal_emit_valist
[30] g_signal_emit
[31] gtk_container_propagate_draw
[32] g_closure_invoke
[33] g_signal_emit_valist
[34] g_signal_emit
[35] gtk_container_propagate_draw
[36] g_closure_invoke
[37] g_signal_emit_valist
[38] g_signal_emit
[39] gtk_container_propagate_draw
[40] g_closure_invoke
[41] g_signal_emit_valist
[42] g_signal_emit
[43] gtk_container_propagate_draw
[44] gtk_container_propagate_draw
[45] gtk_main_do_event
[46] g_signal_emit_valist
[47] g_signal_emit
[48] g_main_context_dispatch
[49] g_main_loop_run
[50] gtk_main
[51] wxGUIEventLoop::DoRun()
[52] wxEventLoopBase::Run()
[53] wxAppConsoleBase::MainLoop()
[54] wxEntry(int&, wchar_t**)
[55] main
[56] __libc_start_main
[57] _start

END]

Again, this is Kubuntu 20.04.2 with all updates they send my way. Thank You for any assistance you can provide to fix this.
xminusone
Posts: 8
Joined: Fri Jan 17, 2020 11:19 pm

Re: It was working fine--

Post by xminusone »

I was actually able to use it quite successfully earlier today, for about a half-hour or so, then it crashed in the background and won't hardly open without crashing. The splash comes up, and WHAM! Two backtraces one right after the other. The first one is the one I have already posted, and this is the second one:

[START:

ASSERT INFO:
../src/common/datetime.cpp(1392): assert "IsValid()" failed in GetTm(): invalid wxDateTime

BACKTRACE:
[1] wxDateTime::GetTm(wxDateTime::TimeZone const&) const
[2] wxDateTime::Format(wxString const&, wxDateTime::TimeZone const&) const
[3] Guayadeque::guSoListBox::OnGetItemText(int, int) const
[4] Guayadeque::guListViewClient::DoDrawItem(wxDC&, wxRect const&, int, int) const
[5] Guayadeque::guListViewClient::OnDrawItem(wxDC&, wxRect const&, unsigned long) const
[6] Guayadeque::guListViewClient::OnPaint(wxPaintEvent&)
[7] wxEvtHandler::ProcessEventIfMatchesId(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&)
[8] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*)
[9] wxEvtHandler::TryHereOnly(wxEvent&)
[10] wxEvtHandler::ProcessEventLocally(wxEvent&)
[11] wxEvtHandler::ProcessEvent(wxEvent&)
[12] wxVarScrollHelperEvtHandler::ProcessEvent(wxEvent&)
[13] wxEvtHandler::SafelyProcessEvent(wxEvent&)
[14] wxWindow::GTKSendPaintEvents(_cairo*)
[15] g_closure_invoke
[16] g_signal_emit_valist
[17] g_signal_emit
[18] gtk_container_propagate_draw
[19] gtk_container_propagate_draw
[20] g_closure_invoke
[21] g_signal_emit_valist
[22] g_signal_emit
[23] gtk_container_propagate_draw
[24] gtk_container_propagate_draw
[25] g_closure_invoke
[26] g_signal_emit_valist
[27] g_signal_emit
[28] gtk_container_propagate_draw
[29] g_closure_invoke
[30] g_signal_emit_valist
[31] g_signal_emit
[32] gtk_container_propagate_draw
[33] g_closure_invoke
[34] g_signal_emit_valist
[35] g_signal_emit
[36] gtk_container_propagate_draw
[37] g_closure_invoke
[38] g_signal_emit_valist
[39] g_signal_emit
[40] gtk_container_propagate_draw
[41] g_closure_invoke
[42] g_signal_emit_valist
[43] g_signal_emit
[44] gtk_container_propagate_draw
[45] gtk_container_propagate_draw
[46] gtk_main_do_event
[47] g_signal_emit_valist
[48] g_signal_emit
[49] g_main_context_dispatch
[50] g_main_loop_run
[51] gtk_main
[52] wxGUIEventLoop::DoRun()
[53] wxEventLoopBase::Run()
[54] wxAppConsoleBase::MainLoop()
[55] wxEntry(int&, wchar_t**)
[56] main
[57] __libc_start_main
[58] _start

END]

I haven't the slightest idea what goes on. Nothing else is awry on the system (that I'm aware of). Could it have something to do with the amount of files in my collection (180k)? The other music players grind along with that heft, but none of them crash (Clementine, Strawberry, QMMP, Quod Libet, Foobar, Audacious, even Winamp!). And, sure, I could use any one or a couple of those, but yours is my favorite by far, anonbeat! I hope this can be fixed.
User avatar
anonbeat
Posts: 2028
Joined: Thu Sep 16, 2010 9:47 pm

Re: It was working fine--

Post by anonbeat »

I will try to mount a virtual machine to compile it and see what could be
User avatar
anonbeat
Posts: 2028
Joined: Thu Sep 16, 2010 9:47 pm

Re: It was working fine--

Post by anonbeat »

Can you send me the guayadeque.db file so I can do some checks ?
xminusone
Posts: 8
Joined: Fri Jan 17, 2020 11:19 pm

guayadeque.db file size

Post by xminusone »

I will be happy to send you the db file, anonbeat, but I want to ask first: the file is 645mb, can I send it through the forum here, or should I make other arrangements to make the db file available to you?

Thank you so much for replying.
User avatar
anonbeat
Posts: 2028
Joined: Thu Sep 16, 2010 9:47 pm

Re: It was working fine--

Post by anonbeat »

The file is huge... Better if you can upload to google drive or something like this... And please try to compress it.

Thanks
xminusone
Posts: 8
Joined: Fri Jan 17, 2020 11:19 pm

db link

Post by xminusone »

I've submitted the file for your perusal at mediafire. Got it down to about 260mb.
User avatar
anonbeat
Posts: 2028
Joined: Thu Sep 16, 2010 9:47 pm

Re: It was working fine--

Post by anonbeat »

Thanks. I checked with your database and everyting is working fine. The dates are converted correctly. Will go for the virtual machine.
User avatar
anonbeat
Posts: 2028
Joined: Thu Sep 16, 2010 9:47 pm

Re: It was working fine--

Post by anonbeat »

Everything is fine here... dont see what is going on. Sorry, cant help you out.
Post Reply