Ubuntu 20.04 + python3 = no conkyguayadeque

General discussions
Post Reply
rizlaw
Posts: 8
Joined: Tue Jun 11, 2019 4:05 pm

Ubuntu 20.04 + python3 = no conkyguayadeque

Post by rizlaw »

With Ubuntu 20.04 LTS we got Python3 (Python2 was deprecated). With Python3 we got broken Python2 conky scripts, most of which were written back in 2011 and never updated (as far as I can tell). The "conkyguayadeque" PPA mentioned in the Guayadeque online manual under "Conky" is also ancient and doesn't work:

Code: Select all

Err:23 http://ppa.launchpad.net/conky-companions/ppa/ubuntu focal Release
  404  Not Found [IP: 91.189.95.83 80]
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/conky-companions/ppa/ubuntu focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
As a non-programmer I did a little research and found what I hoped would be an easy and simple solution, a little Python program called "2to3" which is supposed to convert Python2 scripts to Python3 (for example: 2to3 -w conkyguayadeque.py). Converting my python2 Guayadeque conky script didn't work.

Unfortunately, Guayadeque doesn't have Audacious' Audtool nor Quodlibet's "Internal Tags" which can be used in Conky to get the needed song playing info out of Audacious or Quodlibet and into Conky to be displayed.

So does anybody have any ideas?

Post Reply