Segfault; rev 1679

Post Reply
l300lvl
Posts: 226
Joined: Sun Mar 06, 2011 12:21 pm

Segfault; rev 1679

Post by l300lvl »

I didnt want to cause confusion so I'm putting this in its own thread: This happened by mounting another volume/choosing a seperate partition as a source. After crashing it was left running and I had to use 'force quit' or killall to end process.

The window "Unknown - Guayadeque Music Player 0.3.4-1679" is not responding.

[Thread 0x7fffc46f8700 (LWP 3716) exited]
01:47:02 PM: Sent Event to open collection
01:47:02 PM: OnCollectionCommand 13163 3 0 1
01:47:02 PM: MediaViewer Not Found for '4EB3D7E1'
01:47:02 PM: MediaViewer '4.0 GB Filesystem' => '4EB3D7E1' ==>> 00E13D90
01:47:02 PM: Created collection folder '/home/l300lvl/.guayadeque/Collections/4EB3D7E1'
01:47:02 PM: Unknown audio mime type : 'mp3'
01:47:02 PM: Unknown playlist mime type : 'jpeg'
01:47:02 PM: Error: Failed to create a temporary file name (error 13: Permission denied)
01:47:02 PM: Error: can't open user configuration file.
01:47:02 PM: Error: Failed to create a temporary file name (error 13: Permission denied)
01:47:02 PM: Error: can't open user configuration file.
01:47:02 PM: Library Db Version 0
01:47:02 PM: Updating database version to 21
01:47:02 PM: SetViewMode -1 => 0
01:47:02 PM: guLibPanel::IniPanelData( 13164 )
01:47:02 PM: guLibPanel::DoTextSearch( '' )
01:47:02 PM: Mount: '4.0 GB Filesystem' => '/media/3cc4fdab-edba-473f-bd94-886a0676cfb2/'
01:47:02 PM: OnCollectionCommand 13177 3 14 0
[New Thread 0x7fffc46f8700 (LWP 3859)]
01:47:02 PM: Doing Library Update in /media/3cc4fdab-edba-473f-bd94-886a0676cfb2/
01:47:03 PM: Could not open the dir '/media/3cc4fdab-edba-473f-bd94-886a0676cfb2/tmp/orbit-root/'
01:47:03 PM: Could not open the dir '/media/3cc4fdab-edba-473f-bd94-886a0676cfb2/var/lib/gdm/'
01:47:03 PM: Could not open the dir '/media/3cc4fdab-edba-473f-bd94-886a0676cfb2/var/lib/sudo/'
01:47:03 PM: Could not open the dir '/media/3cc4fdab-edba-473f-bd94-886a0676cfb2/var/lib/polkit-1/'
01:47:03 PM: Could not open the dir '/media/3cc4fdab-edba-473f-bd94-886a0676cfb2/var/cache/ldconfig/'
01:47:03 PM: Could not open the dir '/media/3cc4fdab-edba-473f-bd94-886a0676cfb2/var/log/gdm/'
01:47:03 PM: Could not open the dir '/media/3cc4fdab-edba-473f-bd94-886a0676cfb2/var/log/samba/cores/'
01:47:03 PM: Could not open the dir '/media/3cc4fdab-edba-473f-bd94-886a0676cfb2/var/spool/cron/atjobs/'
01:47:03 PM: Could not open the dir '/media/3cc4fdab-edba-473f-bd94-886a0676cfb2/var/spool/cron/crontabs/'
01:47:03 PM: Could not open the dir '/media/3cc4fdab-edba-473f-bd94-886a0676cfb2/var/spool/cron/atspool/'
01:47:03 PM: Could not open the dir '/media/3cc4fdab-edba-473f-bd94-886a0676cfb2/var/spool/cups/'
01:47:03 PM: Could not open the dir '/media/3cc4fdab-edba-473f-bd94-886a0676cfb2/root/'
01:47:12 PM: Mount: '4.0 GB Filesystem' => '/media/3cc4fdab-edba-473f-bd94-886a0676cfb2/'

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffc46f8700 (LWP 3859)]
wxSQLite3Database::CheckDatabase (this=0x76c2f44dab911d35) at /home/l300lvl/guayadeque/src/wxsqlite3/wxsqlite3.cpp:2499
2499 if (!m_db)

i forgot to do bt and now im trying to reproduce this but it seems everytime i unmount and try to remount the volume it reproduces the entry leaving me with whats now 4 '4.0 GB Filesystem' entries, I tried exiting out of gdb and reopening it so now I'm going to try restarting to see if I can get a bt.

l300lvl
Posts: 226
Joined: Sun Mar 06, 2011 12:21 pm

Segfault; rev 1679

Post by l300lvl »

So after restarting I attempted again and I now have 3 black entries of '4.0 GB Filesystem' and I was wondering how I can remove these? The only thing I can think is it remembers the player based on uuid/path but it would seem something changes each time that causes it to create a new entry when its removed/unmounted.

User avatar
anonbeat
Posts: 1994
Joined: Thu Sep 16, 2010 9:47 pm

Segfault; rev 1679

Post by anonbeat »

Go to Preferences -> Collections and remove the collection entries you dont want anymore.

Can you send me what continues with the backtrace or explain me exactly what you did to get this problem ?

Thanks for your help

l300lvl
Posts: 226
Joined: Sun Mar 06, 2011 12:21 pm

Segfault; rev 1679

Post by l300lvl »

Thanks for the help. I got them removed and I tried restarting first so the device wasn't mounted but it seems no matter what I do I can't get it to crash again, what I can say is I was playing an mp4 at the time, other than that I'm clueless as to why it could have happened but if it ever does again I'll remember to do the friggin bt. Sorry about that and thanks for all the hard work!

Post Reply