Gstreamer 1.0 and wxWidgets 3.0 porting bug reports.

Use this category to discuss anything related to the development of Guayadeque.
Post Reply
User avatar
anonbeat
Posts: 1956
Joined: Thu Sep 16, 2010 9:47 pm

Gstreamer 1.0 and wxWidgets 3.0 porting bug reports.

Post by anonbeat » Wed Jun 29, 2016 7:10 am

Please check with latest commit. It should be fixed.

Thanks for your help

bda
Posts: 7
Joined: Sat Jun 25, 2016 4:49 am

Gstreamer 1.0 and wxWidgets 3.0 porting bug reports.

Post by bda » Thu Jun 30, 2016 12:49 am

Thank you. Do I download it from your ppa?

User avatar
anonbeat
Posts: 1956
Joined: Thu Sep 16, 2010 9:47 pm

Gstreamer 1.0 and wxWidgets 3.0 porting bug reports.

Post by anonbeat » Thu Jun 30, 2016 2:19 am

It will be available in the ppa in a few minutes... check it for updates

Thank you very much

dip
Posts: 21
Joined: Sat Jul 02, 2016 6:19 pm

Gstreamer 1.0 and wxWidgets 3.0 porting bug reports.

Post by dip » Fri Jul 08, 2016 6:44 pm

I am just trying to compile from git but are not successful. I am running Linux Mint 17.3 and it seems that libwxsqlite3-3.0-dev is not available. I read in this thread that version 3.3.1 is available from https://sourceforge.net/projects/wxcode ... Components (as mentioned by radiometer). I have to admit that I have no experience with compiling in Linux so I just downloaded the package and run "configure" then "make" and then "sudo make install". I don't know if this was correct but at least there were no error messages.

I then switched to the guayadeque folder and run ./build. However I got the following error:

-- Using install prefix /usr ...
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.26")
-- Found wxWidgets: TRUE
-- checking for module 'gstreamer-1.0'
-- found gstreamer-1.0, version 1.2.4
-- checking for module 'gstreamer-tag-1.0'
-- found gstreamer-tag-1.0, version 1.2.4
-- checking for module 'sqlite3'
-- found sqlite3, version 3.8.2
-- checking for module 'libcurl'
-- found libcurl, version 7.35.0
-- checking for module 'taglib>=1.6.4'
-- found taglib, version 1.9.1
-- checking for module 'dbus-1'
-- found dbus-1, version 1.6.18
-- checking for module 'gdk-pixbuf-2.0'
-- found gdk-pixbuf-2.0, version 2.30.7
-- checking for module 'gio-2.0'
-- found gio-2.0, version 2.40.2
-- checking for module 'libgpod-1.0'
-- found libgpod-1.0, version 0.8.3
-- checking for module 'indicate-0.7'
-- found indicate-0.7, version 12.10.1
-- checking for module 'wxsqlite3'
-- package 'wxsqlite3' not found
-- checking for module 'wxsqlite3-3.0'
-- package 'wxsqlite3-3.0' not found
CMake Error at CMakeLists.txt:88 (MESSAGE):
wxSqlite3 not found


-- Configuring incomplete, errors occurred!
See also "/home/dieter/guayadeque/CMakeFiles/CMakeOutput.log".

I read in this thread that I might need to install pkg-config configuration file for this package... but I don't have any clue what this means.

Could you please point me in the right direction that I can install the latest version of Guayadeque on Linux Mint 17.3. I could already install it in a virtual machine running Linux Mint 18 but I don't want to upgrade my real system since Linux Mint 18 seems to be quite buggy.

Thanks a lot.

dip
Posts: 21
Joined: Sat Jul 02, 2016 6:19 pm

Gstreamer 1.0 and wxWidgets 3.0 porting bug reports.

Post by dip » Fri Jul 08, 2016 7:03 pm

I have now created a file wxsqlite3-3.0.pc in /usr/lib/pkconfig having the contents as posted by anobeat on May 21 in this thread. Now compiling starts but finally I get the following error:

....
[ 81%] Building C object src/CMakeFiles/guayadeque.dir/hmac/sha2.o
[ 82%] Building CXX object src/CMakeFiles/guayadeque.dir/network/Curl.o
[ 82%] Building CXX object src/CMakeFiles/guayadeque.dir/network/Http.o
Linking CXX executable guayadeque
/usr/bin/ld: cannot find -lwxsqlite3-3.0
/usr/bin/ld: cannot find -lwxsqlite3-3.0
collect2: error: ld returned 1 exit status
make[2]: *** [src/guayadeque] Fehler 1
make[1]: *** [src/CMakeFiles/guayadeque.dir/all] Fehler 2
make: *** [all] Fehler 2

Do I have to change something since I have downloaded wxsqlite3-3.3.1 instead of wxsqlite3-3.0? How can I check if wxsqlite3 is installed? Now I am lost.

User avatar
anonbeat
Posts: 1956
Joined: Thu Sep 16, 2010 9:47 pm

Gstreamer 1.0 and wxWidgets 3.0 porting bug reports.

Post by anonbeat » Sat Jul 09, 2016 2:34 am

@dip: Do you have wxsqlite3 installed ? because the linker cant find the libraries...
You may correct the pkg-config file with the correct paths where the library got installed...

dip
Posts: 21
Joined: Sat Jul 02, 2016 6:19 pm

Gstreamer 1.0 and wxWidgets 3.0 porting bug reports.

Post by dip » Sat Jul 09, 2016 5:03 am

How can I check if wxsqlite3 is correctly installed? Which file should exist in which folders?

User avatar
anonbeat
Posts: 1956
Joined: Thu Sep 16, 2010 9:47 pm

Gstreamer 1.0 and wxWidgets 3.0 porting bug reports.

Post by anonbeat » Sat Jul 09, 2016 12:16 pm

dip wrote:How can I check if wxsqlite3 is correctly installed? Which file should exist in which folders?
# Package Information for pkg-config

prefix=/usr
wxver=3.0
includedir=${prefix}/include/wx-${wxver}/
libdir=${prefix}/lib/x86_64-linux-gnu

Name: wxsqlite3-3.0
Description: SQLite3 C++ wrapper for use in programs based on the wxWidgets
Version:
Requires: sqlite3
Libs: -L${libdir} -lwxsqlite3-3.0
Libs.private: -lpthread
Cflags: -I${includedir}

See this file for example...

You should have in /usr/lib/x86_64-linux-gnu the files libwxsqlite3-3.0.so

If you installed wxsqlite3 you saw where the files came to in the install process...

Hope it helps

dip
Posts: 21
Joined: Sat Jul 02, 2016 6:19 pm

Gstreamer 1.0 and wxWidgets 3.0 porting bug reports.

Post by dip » Mon Jul 11, 2016 5:48 pm

I was finally able to compile Guayadeque. I had to adjust the paths in the pkg-file. Further, instead of libwxsqlite3-3.0.so a file libwxcode_gtk2u_wxsqlite3-3.0.so was generated which I renamed to libwxsqlite3-3.0.so.
During my trial and error proceedings I copied several copies of the *.h and *.so files to different directories (until compiling finally worked). I have not cleaned up all files since I thought I have understand the necessary paths and files of the wxsqlite3 library. However, when I now try to compilte Guayadeque I get the following errors (sorry for posting the output directly but uploading a file is not possible::

-- Using install prefix /usr ...
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.26")
-- Found wxWidgets: TRUE
-- checking for module 'gstreamer-1.0'
-- found gstreamer-1.0, version 1.2.4
-- checking for module 'gstreamer-tag-1.0'
-- found gstreamer-tag-1.0, version 1.2.4
-- checking for module 'sqlite3'
-- found sqlite3, version 3.8.2
-- checking for module 'libcurl'
-- found libcurl, version 7.35.0
-- checking for module 'taglib>=1.6.4'
-- found taglib, version 1.9.1
-- checking for module 'dbus-1'
-- found dbus-1, version 1.6.18
-- checking for module 'gdk-pixbuf-2.0'
-- found gdk-pixbuf-2.0, version 2.30.7
-- checking for module 'gio-2.0'
-- found gio-2.0, version 2.40.2
-- checking for module 'libgpod-1.0'
-- found libgpod-1.0, version 0.8.3
-- checking for module 'indicate-0.7'
-- found indicate-0.7, version 12.10.1
-- checking for module 'wxsqlite3'
-- package 'wxsqlite3' not found
-- checking for module 'wxsqlite3-3.0'
-- found wxsqlite3-3.0, version
-- Found Gettext: /usr/bin/msgmerge (found version "0.18.3")
-- Configuring done
-- Generating done
CMake Warning:
Manually-specified variables were not used by the project:

CMAKE_CXX_STANDARD


-- Build files have been written to: /home/dieter/guayadeque
[ 0%] Building CXX object src/CMakeFiles/guayadeque.dir/AlListBox.o
In file included from /usr/include/wx-3.0/wx/debug.h:14:0,
from /usr/include/wx-3.0/wx/defs.h:688,
from /usr/include/wx-3.0/wx/wx.h:14,
from /home/dieter/guayadeque/src/Utils.h:23,
from /home/dieter/guayadeque/src/Db.h:23,
from /home/dieter/guayadeque/src/DbLibrary.h:23,
from /home/dieter/guayadeque/src/AlListBox.h:23,
from /home/dieter/guayadeque/src/AlListBox.cpp:20:
/usr/include/assert.h:37:42: error: missing binary operator before token "("
#if defined __cplusplus && __GNUC_PREREQ (2,95)
^
In file included from /usr/include/wx-3.0/wx/chartype.h:68:0,
from /usr/include/wx-3.0/wx/debug.h:19,
from /usr/include/wx-3.0/wx/defs.h:688,
from /usr/include/wx-3.0/wx/wx.h:14,
from /home/dieter/guayadeque/src/Utils.h:23,
from /home/dieter/guayadeque/src/Db.h:23,
from /home/dieter/guayadeque/src/DbLibrary.h:23,
from /home/dieter/guayadeque/src/AlListBox.h:23,
from /home/dieter/guayadeque/src/AlListBox.cpp:20:
/usr/include/wchar.h:74:43: error: missing binary operator before token "("
# if defined __cplusplus && __GNUC_PREREQ (4, 4)
^
In file included from /usr/include/libio.h:56:0,
from /usr/include/stdio.h:74,
from /usr/include/wx-3.0/wx/string.h:39,
from /usr/include/wx-3.0/wx/longlong.h:19,
from /usr/include/wx-3.0/wx/time.h:13,
from /usr/include/x86_64-linux-gnu/sys/types.h:132,
from /usr/include/wx-3.0/wx/defs.h:1205,
from /usr/include/wx-3.0/wx/wx.h:14,
from /home/dieter/guayadeque/src/Utils.h:23,
from /home/dieter/guayadeque/src/Db.h:23,
from /home/dieter/guayadeque/src/DbLibrary.h:23,
from /home/dieter/guayadeque/src/AlListBox.h:23,
from /home/dieter/guayadeque/src/AlListBox.cpp:20:
/usr/include/x86_64-linux-gnu/sys/cdefs.h:41:20: error: missing binary operator before token "("
# if __GNUC_PREREQ (4, 6) && !defined _LIBC
^
/usr/include/x86_64-linux-gnu/sys/cdefs.h:54:44: error: missing binary operator before token "("
# if !defined __cplusplus && __GNUC_PREREQ (3, 3)
^
/usr/include/x86_64-linux-gnu/sys/cdefs.h:59:44: error: missing binary operator before token "("
# if defined __cplusplus && __GNUC_PREREQ (2,8)
^
/usr/include/x86_64-linux-gnu/sys/cdefs.h:136:19: error: missing binary operator before token "("
#if __GNUC_PREREQ (4,3)
^
/usr/include/x86_64-linux-gnu/sys/cdefs.h:149:19: error: missing binary operator before token "("
#if __GNUC_PREREQ (2,97)
^
/usr/include/x86_64-linux-gnu/sys/cdefs.h:211:19: error: missing binary operator before token "("
#if __GNUC_PREREQ (2,96)
^
/usr/include/x86_64-linux-gnu/sys/cdefs.h:219:19: error: missing binary operator before token "("
#if __GNUC_PREREQ (4, 3)
^

dip
Posts: 21
Joined: Sat Jul 02, 2016 6:19 pm

Gstreamer 1.0 and wxWidgets 3.0 porting bug reports.

Post by dip » Mon Jul 11, 2016 5:49 pm

/usr/include/x86_64-linux-gnu/sys/cdefs.h:229:19: error: missing binary operator before token "("
#if __GNUC_PREREQ (2,96)
^
/usr/include/x86_64-linux-gnu/sys/cdefs.h:236:19: error: missing binary operator before token "("
#if __GNUC_PREREQ (2,5)
^
/usr/include/x86_64-linux-gnu/sys/cdefs.h:245:19: error: missing binary operator before token "("
#if __GNUC_PREREQ (3,1)
^
/usr/include/x86_64-linux-gnu/sys/cdefs.h:254:19: error: missing binary operator before token "("
#if __GNUC_PREREQ (3,2)
^
/usr/include/x86_64-linux-gnu/sys/cdefs.h:266:19: error: missing binary operator before token "("
#if __GNUC_PREREQ (2,8)
^
/usr/include/x86_64-linux-gnu/sys/cdefs.h:276:19: error: missing binary operator before token "("
#if __GNUC_PREREQ (2,97)
^
/usr/include/x86_64-linux-gnu/sys/cdefs.h:285:19: error: missing binary operator before token "("
#if __GNUC_PREREQ (3,3)
^
/usr/include/x86_64-linux-gnu/sys/cdefs.h:293:19: error: missing binary operator before token "("
#if __GNUC_PREREQ (3,4)
^
/usr/include/x86_64-linux-gnu/sys/cdefs.h:307:19: error: missing binary operator before token "("
#if __GNUC_PREREQ (3,2)
^
/usr/include/x86_64-linux-gnu/sys/cdefs.h:315:19: error: missing binary operator before token "("
#if __GNUC_PREREQ (4,3)
^
/usr/include/x86_64-linux-gnu/sys/cdefs.h:341:19: error: missing binary operator before token "("
#if __GNUC_PREREQ (4,3)
^
/usr/include/x86_64-linux-gnu/sys/cdefs.h:350:20: error: missing binary operator before token "("
#if !__GNUC_PREREQ (2,8)
^
/usr/include/x86_64-linux-gnu/sys/cdefs.h:355:20: error: missing binary operator before token "("
#if !__GNUC_PREREQ (2,92)
^
/usr/include/x86_64-linux-gnu/sys/cdefs.h:362:19: error: missing binary operator before token "("
#if __GNUC_PREREQ (3,1) && !defined __GNUG__
^
In file included from /usr/include/x86_64-linux-gnu/c++/4.8/bits/c++config.h:426:0,
from /usr/include/c++/4.8/string:38,
from /usr/include/wx-3.0/wx/stringimpl.h:66,
from /usr/include/wx-3.0/wx/unichar.h:15,
from /usr/include/wx-3.0/wx/strvararg.h:22,
from /usr/include/wx-3.0/wx/string.h:46,
from /usr/include/wx-3.0/wx/longlong.h:19,
from /usr/include/wx-3.0/wx/time.h:13,
from /usr/include/x86_64-linux-gnu/sys/types.h:132,
from /usr/include/wx-3.0/wx/defs.h:1205,
from /usr/include/wx-3.0/wx/wx.h:14,
from /home/dieter/guayadeque/src/Utils.h:23,
from /home/dieter/guayadeque/src/Db.h:23,
from /home/dieter/guayadeque/src/DbLibrary.h:23,
from /home/dieter/guayadeque/src/AlListBox.h:23,
from /home/dieter/guayadeque/src/AlListBox.cpp:20:
/usr/include/x86_64-linux-gnu/c++/4.8/bits/os_defines.h:44:19: error: missing binary operator before token "("
#if __GLIBC_PREREQ(2,15) && defined(_GNU_SOURCE)
^

Post Reply