Crossfading Bug

Use this category to discuss anything related to the development of Guayadeque.
Post Reply
Johanna
Posts: 3
Joined: Fri Dec 06, 2013 6:19 am

Crossfading Bug

Post by Johanna » Fri Dec 06, 2013 6:44 am

short: by using the Cross fading feature it always cuts (not fades) the last 4 seconds of the song, no matter what values i use.

long:
Hi, I love the cross fading feature, especially that it fades the song when i press the stop button. This is just great (I always hated to stop my music that hard)! Thank You for that possibility! The only annoying thing with the cross fading in my case (Xubuntu 13.10 Guayadeque 0.3.5-) is, it fades to early and cuts of about 4 seconds. So it does fade, but it pretends the song (before starting the next one) is about 4 seconds shorter than it really is. So with cross fading enabled there is no way to listen to the last 4 seconds of a song, no matter which options/values i use in the preferences (even e.g. with Fade-In-Start on 1,1).

Any help on this?

Thanks a lot (and for the great "stop=fading"-feature ;-),
Johanna

P.S. It's not very friendly forcing people to register just as man/woman for this board. See e.g.:
http://www.sarahdopp.com/blog/2008/gend ... own-menus/ or
https://www.allout.org/en/actions/facebook - Thanks for concerning...

Johanna
Posts: 3
Joined: Fri Dec 06, 2013 6:19 am

Crossfading Bug

Post by Johanna » Tue Feb 11, 2014 12:44 pm

Hmm, no help on this? :-/

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

Crossfading Bug

Post by anonbeat » Tue Feb 11, 2014 2:19 pm

Im sorry for the late response. Gstreamer reports incorrectly the length for variable bitrates tracks. This is why guayadeque remove just a few seconds of the track at the end to be sure the crossfading ends correctly and the track dont ends suddenly.

Johanna
Posts: 3
Joined: Fri Dec 06, 2013 6:19 am

Crossfading Bug

Post by Johanna » Tue Feb 11, 2014 3:58 pm

Thanks for the explanation! That's very nice of You!
I would prefer a sudden end in the rare cases of variable bitrates tracks instead of missing the last seconds of every file. Is there an option I can switch for this?
Thank You again for Your help and the great program anyway!

Post Reply