Bug in the notifications for new songs

Use this category to discuss anything related to the development of Guayadeque.
Post Reply
siddharthasahu
Posts: 8
Joined: Tue Jan 24, 2012 1:54 pm

Bug in the notifications for new songs

Post by siddharthasahu »

OS: Arch Linux x64 with KDE 4.10.3

The Body.Append function seems not to be working properly on my system. In all notifications, only one star appeared, and the rest of the data was missing. After changing the code as below, it is working properly. Could you please have a look?

Patch:
diff -aur guayadeque/src/PlayerPanel.cpp guayadeque-1/src/PlayerPanel.cpp
--- guayadeque/src/PlayerPanel.cpp 2012-01-25 02:47:56.167437000 +0530
+++ guayadeque-1/src/PlayerPanel.cpp 2013-05-15 14:16:26.690071100 +0530
@@ -3041,7 +3041,8 @@
if( m_MediaSong.m_Rating > 0 )
{
Body += wxT( " " );
- Body.Append( wxT( '?' ), m_MediaSong.m_Rating );
+ for(int i=1; i

Kalantir
Posts: 5
Joined: Mon Oct 21, 2013 6:03 pm

Bug in the notifications for new songs

Post by Kalantir »

I can confirm this bug. I experience it on Arch Linux x86_64 with KDE 4.11.2 while using the SVN build of Guayadeque 0.3.5-1885. This bug was not present in Guayadeque 0.3.5-5.

I have attached a picture to demonstrate the bug. As you can see I have rated the song 5 stars but the notification only shows 1 star and does not display any other information about the song.

Kalantir
Posts: 5
Joined: Mon Oct 21, 2013 6:03 pm

Bug in the notifications for new songs

Post by Kalantir »

I'm just chiming in again to say that I applied siddharthasahu's patch and it works perfectly. I've attached a picture to demonstrate that it works again. Any chance of this patch being added to the official build?

Thank you siddharthasahu for your patch and thank you anonbeats for providing us with the best damn music player I've ever used.

User avatar
anonbeat
Posts: 1993
Joined: Thu Sep 16, 2010 9:47 pm

Bug in the notifications for new songs

Post by anonbeat »

I will do it asap.

Thanks for your help

kinggo
Posts: 247
Joined: Thu Feb 09, 2012 5:54 am

Bug in the notifications for new songs

Post by kinggo »

I'm not sure if this is the reason but since this was the last change.......
After updating to 1886 I don't have guayadeque under notifications on gnome shell. The ratings are visible now but there's nothing to set. I have two "network" items. Anybody else?

User avatar
anonbeat
Posts: 1993
Joined: Thu Sep 16, 2010 9:47 pm

Bug in the notifications for new songs

Post by anonbeat »

Not my case. I see it in sound menu. Dont use gnome shell thought. I use xfce.

kinggo
Posts: 247
Joined: Thu Feb 09, 2012 5:54 am

Bug in the notifications for new songs

Post by kinggo »

sound menu is fine. And in GS it works via some extension. But there are settings for notification in which you can set up how, when and where do you want the notifications to pop-up.
this.... http://3.bp.blogspot.com/-nQUraBCcL8s/U ... ings_2.png
And now guayadeque is gone from there. Can I somehow go back to 1885 to see if it's guayadeque or something in gnome.
And also, have you done some changes regarding taskbar icon? Because now it works on GS if "integrate into sound menu" is off and before it didn't work. Only in some rare random cases but I never managed to make it persistent or find some pattern how to activate it but that never bothered me much because only useful difference between icon and GS extension is that with icon I can set rating. Which is nice but not something that I can't live without.

User avatar
anonbeat
Posts: 1993
Joined: Thu Sep 16, 2010 9:47 pm

Bug in the notifications for new songs

Post by anonbeat »

No. The changes was only about a bug in wxWidgets that it was affecting the number of starts in the message displayed in the notification. But nothing else changed about notifications.

kinggo
Posts: 247
Joined: Thu Feb 09, 2012 5:54 am

Bug in the notifications for new songs

Post by kinggo »

hmmmm....... quayadeque completely ignore all notification settings even if I do changes with dconf editor. Everything is always on.

kinggo
Posts: 247
Joined: Thu Feb 09, 2012 5:54 am

Bug in the notifications for new songs

Post by kinggo »

well, deleting Guayadeque Music Player from /usr/share/applications and copying guayadeque.desktop from my /home/guayadeque fixed it. It's back in notifications and changes have effect.
But aren't those two files actually the same? After copying it renamed itself to Guayadeque Music Player. And creation date was the same for both of them in the first place so I suppose that it should have been fine the first time.

Post Reply