Error when advancing or changing song in Magnatune

Use this category to discuss anything related to the development of Guayadeque.
Post Reply
geraba
Posts: 4
Joined: Mon Mar 18, 2013 5:45 pm

Error when advancing or changing song in Magnatune

Post by geraba » Mon Mar 18, 2013 5:54 pm

Hello.

I noticed a bug when using a playlist from Magnatune. After you let it play a few songs, the highlighted song in the playlist is actually the next song then the one being played. For example, if the playlist now is:

A
B
C
D

and B is really being played now, the song that is highlighted is actually C:

A
B -> actually being played
C* -> highlighted
D

Also, after playing a few songs, if you try to advance 1 track, either the Next Song command/button does not work, or it skips 2 tracks.

To reset the problem, you have to double click the actual track in the playlist (B, in the previous example). When you do so, the player tries to load the song, and then skips to the next, effectively playing the song next to the one you clicked (C, in the example).

I hope my explanation is clear enough.

Congratulations on the great player, it was just what I was looking for in Linux.

P.S.: I forgot to mention: I use Guayadeque 0.3.5~, that installs from Ubuntu Software Center in 12.04.

User avatar
anonbeat
Posts: 1956
Joined: Thu Sep 16, 2010 9:47 pm

Error when advancing or changing song in Magnatune

Post by anonbeat » Tue Mar 19, 2013 6:35 pm

Can you tell me what are you playback settings and crossfading settings please ?
I have been checking with many short tracks and it its going fine here.

Thanks for your help

geraba
Posts: 4
Joined: Mon Mar 18, 2013 5:45 pm

Error when advancing or changing song in Magnatune

Post by geraba » Wed Mar 20, 2013 8:30 am

I have disabled crossfading by setting the 3 first setting to 0 (FI length, FO length and FI volume), and FI start is at 1.0, since I cannot decrease it any further.

What playback settings do you want to know? I'm streaming using .ogg, using Replay Gain in Track mode, 6 dB pre amp. I'm not using the silence detector.

Are there more relevant settings?

Also, I noticed a detail that may help to debug the problem: about 2 seconds short of ending the current song (when there's Magnatunes' propaganda), the audio halts for ~1 second, then resumes the last 2 seconds and skips to the next song. Maybe the problems are correlated. Also, my playlist has 6622 songs, as I enabled a few musical genres and added all songs to the playlist.

Thanks for the support.

User avatar
anonbeat
Posts: 1956
Joined: Thu Sep 16, 2010 9:47 pm

Error when advancing or changing song in Magnatune

Post by anonbeat » Wed Mar 20, 2013 8:34 am

If you have set the first crossfader value to 0 that means its disables and you cant change the other ones as it is disabled. I will try and test with that settings.
About playback settings do you have silence detector enabled ?

geraba
Posts: 4
Joined: Mon Mar 18, 2013 5:45 pm

Error when advancing or changing song in Magnatune

Post by geraba » Wed Mar 20, 2013 11:27 am

Even when the first crossfader has a finite value, I cannot decrease the last one to 0. It works fine for me even with the residual 1.
My silence detector is disabled.

I just noticed something: I was with Guayadeque window in focus, and the playlist problem was there (B was playing, and C was highlighted). While still in focus, the song changed to the next, so C started playing, but it still was highlighted.

So, I think that this bug only happens when Guayadeque is out of focus, as it is most of the time I use it. Perhaps you can try to reproduce it again, with the player window out of focus?

geraba
Posts: 4
Joined: Mon Mar 18, 2013 5:45 pm

Error when advancing or changing song in Magnatune

Post by geraba » Wed Mar 20, 2013 11:33 am

Here is a screenshot from the problem: The song being actually played is Rosenmuller Sonata, but the highlighted song is BWV1003, the next song.

User avatar
anonbeat
Posts: 1956
Joined: Thu Sep 16, 2010 9:47 pm

Error when advancing or changing song in Magnatune

Post by anonbeat » Wed Mar 20, 2013 12:17 pm

geraba wrote:Even when the first crossfader has a finite value, I cannot decrease the last one to 0. It works fine for me even with the residual 1.
My silence detector is disabled.

I just noticed something: I was with Guayadeque window in focus, and the playlist problem was there (B was playing, and C was highlighted). While still in focus, the song changed to the next, so C started playing, but it still was highlighted.

So, I think that this bug only happens when Guayadeque is out of focus, as it is most of the time I use it. Perhaps you can try to reproduce it again, with the player window out of focus?
Will try. Thanks for your help

Post Reply