gstreamer-0.10 not found!

Use this category to discuss anything related to the development of Guayadeque.
bmbaker
Posts: 72
Joined: Tue Oct 19, 2010 3:12 am

gstreamer-0.10 not found!

Post by bmbaker » Tue Nov 27, 2012 3:26 am

i was just doing a new pull from svn and have run into buildd error!

bb@bb-quantal:~/guayadeque$ ./buildd
rm: cannot remove `CMakeCache.txt': No such file or directory
-- The C compiler identification is GNU 4.7.2
-- The CXX compiler identification is GNU 4.7.2
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Using install prefix /usr ...
-- Found PkgConfig: /opt/gnome/bin/pkg-config (found version "0.25")
-- Found wxWidgets: TRUE
-- checking for module 'gstreamer-0.10'
-- package 'gstreamer-0.10' not found
CMake Error at CMakeLists.txt:36 (MESSAGE):
gstreamer-0.10 not found!


-- Configuring incomplete, errors occurred!

I think its because i have gstreamer 1.0 as well as gstreamer-0.10 on my system.
I have purged the gstreamer 1.0 twice now but i still can't get guaya to build !!
i saw this article it might be why i can't build!
http://www.phoronix.com/scan.php?page=n ... px=MTIzNjQ
running ubuntu 12.10 with GS 3.7.2

kinggo
Posts: 237
Joined: Thu Feb 09, 2012 5:54 am

gstreamer-0.10 not found!

Post by kinggo » Tue Nov 27, 2012 4:39 am

gnome ppa is a mess at the moment. There are many reports of broken systems after updates. And they did fixed some things but there are still some problems with their ppa.

bmbaker
Posts: 72
Joined: Tue Oct 19, 2010 3:12 am

gstreamer-0.10 not found!

Post by bmbaker » Tue Nov 27, 2012 11:39 am

ya i don't see any real breakages at the moment but then again i am also using the testing and staging ppa's plus i manually add the 3.7.2 parts like nautilus etc.
i will do an upgrade to to raring the next days and see how guay functions there too :-)
i wonder if Anonbeat can put the gstreamer1 into action :-)

synapscape
Posts: 2
Joined: Wed Sep 07, 2011 5:33 am

gstreamer-0.10 not found!

Post by synapscape » Thu Dec 06, 2012 4:57 am

Hmm, you do have the gstreamer-0.10 devel package installed? i think it's called libgstreamer0.10-dev

bmbaker
Posts: 72
Joined: Tue Oct 19, 2010 3:12 am

gstreamer-0.10 not found!

Post by bmbaker » Thu Dec 06, 2012 12:23 pm

hmmm yes i do have it installed ;-)

Flo
Posts: 5
Joined: Fri Dec 07, 2012 11:22 pm

gstreamer-0.10 not found!

Post by Flo » Sun Dec 09, 2012 1:15 am

i had the same issue and solved it by installing the non-dev version libgstreamer0.10.

bmbaker
Posts: 72
Joined: Tue Oct 19, 2010 3:12 am

gstreamer-0.10 not found!

Post by bmbaker » Sun Dec 09, 2012 8:13 am

I have all the dependencies installed :-)
perhaps Anon as an idea ?
:-)

bmbaker
Posts: 72
Joined: Tue Oct 19, 2010 3:12 am

gstreamer-0.10 not found!

Post by bmbaker » Sun Dec 09, 2012 8:34 am

hmmm something is wrong indeed i decided to bypass the gstreamer check and ./build failed at the sqlite3
Found PkgConfig: /opt/gnome/bin/pkg-config (found version "0.25")
-- Found wxWidgets: TRUE
-- checking for module 'sqlite3'
-- package 'sqlite3' not found
CMake Error at CMakeLists.txt:46 (MESSAGE):
sqlite3 not found!


-- Configuring incomplete, errors occurred!

I am wondering if something is missing from my path?

bmbaker
Posts: 72
Joined: Tue Oct 19, 2010 3:12 am

gstreamer-0.10 not found!

Post by bmbaker » Sun Dec 09, 2012 8:51 am

duh ! i figured it out
i had /opt/gnome/bin/ to early in my path!

Vamps
Posts: 2
Joined: Mon Feb 11, 2013 3:43 am

gstreamer-0.10 not found!

Post by Vamps » Mon Feb 11, 2013 3:49 am

hello all. i've just installed Qauya on Crunchbang linux, which is a debian based distro. I install quaya with apt-get install from CLI. after loading my mp3s i selected just a few songs. first i got the gstreamer not found common error, after reading a bit here i went ahead and installed both the non dev and dev packages of libgstreamer0.10. after that.. i'm still gettin a gstreamer error on mp3 play back. Any thoughts as to why i might by gettin it and what i need to do to fix it. I've used Guaya before, and if i remember correctly with no problems on install or using it with mp3 files. thanks for helping. and for a great media player.
Yours Kindly.
Vamps.

Post Reply