Sound menu issue

Use this category to discuss anything related to the development of Guayadeque.
Wawanakwa
Posts: 8
Joined: Thu Nov 08, 2012 9:22 am

Sound menu issue

Post by Wawanakwa » Wed Nov 21, 2012 9:48 am

It still doesn't work, after reinstalling everything the situation hasn't changed. And now I'm having problems with my current audio player as well.

synapscape
Posts: 2
Joined: Wed Sep 07, 2011 5:33 am

Sound menu issue

Post by synapscape » Thu Dec 06, 2012 5:02 am

Maybe it's a problem in the pulseaudio config in ~/.pulse? Try renaming it, then logout and login again, or restart pulseaudio...

Wawanakwa
Posts: 8
Joined: Thu Nov 08, 2012 9:22 am

Sound menu issue

Post by Wawanakwa » Mon Feb 11, 2013 12:17 pm

After trying again, I ran guayadeque from terminal and in debug, and this is the result:

18:14:31: Initialized locale ( it_IT )
18:14:31: Mount Added...
18:14:31: Mount Path: /media/riccardo/Disk1/
18:14:31: IconStr: '. GThemedIcon media-optical-dvd-rom media-optical-dvd media-optical media'
18:14:31: MediaViewer 'Musica' => '51193040' ==>> 00000000
18:14:31: Library Db Version 21
18:14:31: SetViewMode -1 => 0
18:14:31: guLibPanel::IniPanelData( 13101 )
18:14:31: guLibPanel::DoTextSearch( '' )
18:14:32: Mount: 'Disk1' => '/media/riccardo/Disk1/'
18:14:32: OnCollectionCommand 13100 0 0 1
18:14:32: Mount: 'Disk1' => '/media/riccardo/Disk1/'
18:14:32: Volume Added...
18:14:32: Volume Added...
18:14:32: Mount Added...
18:14:32: Mount already added?
18:14:32: guMainFrame::OnVolumeMonitorUpdated

(guayadeque:2751): LIBDBUSMENU-GTK-CRITICAL **: watch_submenu: assertion `GTK_IS_MENU_SHELL(menu)' failed

(guayadeque:2751): LIBDBUSMENU-GTK-CRITICAL **: watch_submenu: assertion `GTK_IS_MENU_SHELL(menu)' failed

(guayadeque:2751): LIBDBUSMENU-GTK-CRITICAL **: watch_submenu: assertion `GTK_IS_MENU_SHELL(menu)' failed

(guayadeque:2751): LIBDBUSMENU-GTK-CRITICAL **: watch_submenu: assertion `GTK_IS_MENU_SHELL(menu)' failed

(guayadeque:2751): LIBDBUSMENU-GTK-CRITICAL **: watch_submenu: assertion `GTK_IS_MENU_SHELL(menu)' failed
18:14:32: Mount: 'Disk1' => '/media/riccardo/Disk1/'
18:14:32: Updating the podcasts...
18:14:32: Loading 0 -1 => 0 '--debug'
18:14:32: Error: File doesnt exist '--debug'
18:14:42: Destroying the volume monitor object...
18:14:42: >> ~guGIO_VolumeMonitor()
18:14:42:

User avatar
anonbeat
Posts: 1958
Joined: Thu Sep 16, 2010 9:47 pm

Sound menu issue

Post by anonbeat » Mon Feb 11, 2013 5:03 pm

in debug doesnt mean running with --debug as parameter. You need to compile it from source code using the ./buildd script instead of ./build

For that output I dont see a crash. Looks like if guayadeque closed correctly.

Wawanakwa
Posts: 8
Joined: Thu Nov 08, 2012 9:22 am

Sound menu issue

Post by Wawanakwa » Tue Feb 12, 2013 9:33 am

Sorry, I didn't know that. It was closed correctly because I closed it.
I stil don't understand why there is the line
18:14:42: Destroying the volume monitor object...

User avatar
anonbeat
Posts: 1958
Joined: Thu Sep 16, 2010 9:47 pm

Sound menu issue

Post by anonbeat » Tue Feb 12, 2013 10:40 am

The program writes this message when its closing and need to delete the memory reserved for this object.

Post Reply