A crash from libc when using 'Copy to...'

Use this category to discuss anything related to the development of Guayadeque.
Post Reply
mr_hangman
Posts: 70
Joined: Tue Sep 28, 2010 12:22 am

A crash from libc when using 'Copy to...'

Post by mr_hangman » Sun Oct 24, 2010 11:21 am

I just downgraded from curl 7.21.2 to 7.21.1 in archlinux.
When I tried to copy some songs using 'Copy to...' with 'Default' pattern, it crashed with some more debug information.
It doesn't happen every time but only to some songs. I can track down those songs if you need them.
I'm on r 1306 at the moment.

Program received signal SIGSEGV, Segmentation fault.
0xb72be5b8 in wcslen () from /lib/libc.so.6
(gdb) bt
#0 0xb72be5b8 in wcslen () from /lib/libc.so.6
#1 0xb72bf8f5 in wcsrtombs () from /lib/libc.so.6
#2 0xb7f2e067 in wxWC2MB(char*, wchar_t const*, unsigned int) ()
from /usr/lib/libwx_baseu-2.8.so.0
#3 0xb7f0d08b in wxMBConvLibc::WC2MB(char*, wchar_t const*, unsigned int) const () from /usr/lib/libwx_baseu-2.8.so.0
#4 0xb7f0dbc4 in wxMBConv::cWC2MB(wchar_t const*) const ()
from /usr/lib/libwx_baseu-2.8.so.0
#5 0xb7f2f275 in wxAtoi(wchar_t const*) () from /usr/lib/libwx_baseu-2.8.so.0
#6 0x0814a5e1 in guMainFrame::OnCopyTracksTo (this=0x85193c0, event=...)
at /home/tian/guayadeque/src/MainFrame.cpp:1955
#7 0xb7ebf3ff in wxAppConsole::HandleEvent(wxEvtHandler*, void (wxEvtHandler::*)(wxEvent&), wxEvent&) const () from /usr/lib/libwx_baseu-2.8.so.0
#8 0xb7f514d9 in wxEvtHandler::ProcessEventIfMatches(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&) () from /usr/lib/libwx_baseu-2.8.so.0
#9 0xb7f518f2 in wxEvtHandler::SearchDynamicEventTable(wxEvent&) ()
from /usr/lib/libwx_baseu-2.8.so.0
#10 0xb7f519e3 in wxEvtHandler::ProcessEvent(wxEvent&) ()
from /usr/lib/libwx_baseu-2.8.so.0
#11 0xb7f51416 in wxEvtHandler::ProcessPendingEvents() ()
from /usr/lib/libwx_baseu-2.8.so.0
#12 0xb7ebf7e9 in wxAppConsole::ProcessPendingEvents() ()
from /usr/lib/libwx_baseu-2.8.so.0
---Type to continue, or q to quit---
#13 0xb7cea7ff in wxAppBase::ProcessIdle() ()
from /usr/lib/libwx_gtk2u_core-2.8.so.0
#14 0xb7c49f28 in wxapp_idle_callback ()
from /usr/lib/libwx_gtk2u_core-2.8.so.0
#15 0xb77d8a81 in ?? () from /usr/lib/libglib-2.0.so.0
#16 0xb77dcb72 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#17 0xb77dd350 in ?? () from /usr/lib/libglib-2.0.so.0
#18 0xb77dda1b in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#19 0xb6f6f409 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#20 0xb7c60898 in wxEventLoop::Run() () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#21 0xb7cea5ee in wxAppBase::MainLoop() ()
from /usr/lib/libwx_gtk2u_core-2.8.so.0
#22 0xb7ce9f31 in wxAppBase::OnRun() () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#23 0xb7ef516b in wxEntry(int&, wchar_t**) ()
from /usr/lib/libwx_baseu-2.8.so.0
#24 0xb7ef5217 in wxEntry(int&, char**) () from /usr/lib/libwx_baseu-2.8.so.0
#25 0x0814499b in main (argc=1, argv=0xbffff7c4)
at /home/tian/guayadeque/src/MainApp.cpp:36
(gdb)

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

A crash from libc when using 'Copy to...'

Post by anonbeat » Sun Oct 24, 2010 12:14 pm

If always happens with some tracks please send me one or two to test here

Thanks for your help

mr_hangman
Posts: 70
Joined: Tue Sep 28, 2010 12:22 am

A crash from libc when using 'Copy to...'

Post by mr_hangman » Sun Oct 24, 2010 12:34 pm

Not sure about this but it seems to happen with the artists not the songs (or the path?).
I'm sending the songs and my guayadeque.db in case in might be useful.

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

A crash from libc when using 'Copy to...'

Post by anonbeat » Sun Oct 24, 2010 12:45 pm

Can you open the Preferences and then select the Copy To pane and press accept on it ?
Then try to 'copy to' one of this tracks and let me know if still crashes or not

Thanks for your help

mr_hangman
Posts: 70
Joined: Tue Sep 28, 2010 12:22 am

A crash from libc when using 'Copy to...'

Post by mr_hangman » Sun Oct 24, 2010 1:04 pm

Yes! That solved the problem.
I'm sure I pressed it once when I lost the 'Copy to' function in the right click menu.
So the little green accept button already greyed out. Then I delete 't' from 'Default', retype it and press accept. Now it's working like a charm.
Could you somehow explain roughly what the problem was?
Thank you very much.

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

A crash from libc when using 'Copy to...'

Post by anonbeat » Sun Oct 24, 2010 1:44 pm

The problem was that I introduced recentrly the possibility to move tracks when doing the 'copy to' and you had this param missing.
It was added now you went to that pane and accepted the preferences.

mr_hangman
Posts: 70
Joined: Tue Sep 28, 2010 12:22 am

A crash from libc when using 'Copy to...'

Post by mr_hangman » Sun Oct 24, 2010 3:07 pm

I got it. Thank you very much for the clarification :)

Post Reply