New Guayadeque with Collections Support now up in svn

Use this category to discuss anything related to the development of Guayadeque.
Post Reply
User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

New Guayadeque with Collections Support now up in svn

Post by anonbeat » Sun Dec 18, 2011 1:16 am

Garak wrote:Hi anon,
I have just noticed that the player starts with the first track in the play list, after closing and reopening guayadeque when the option „restore the play position“ is activated. I tried that with the option „restore the play position for tracks longer than 3 minutes.
Garak
Im sorry but I dont understand you correctly. Can you explain me in more detail what the problem is and how to reproduce it ?

Garak
Posts: 11
Joined: Sun Jul 24, 2011 5:06 am

New Guayadeque with Collections Support now up in svn

Post by Garak » Tue Dec 20, 2011 5:47 am

I will try it (and sorry for my bad English).
I play (e.g.) an album with 10 tracks. After the third track, I close Guayadeque. When I'm opening the player next time, it should be continue playing at the position (in the third track), when I closed guayadeque before. For this, I had set the option „restore position for track longer than (e.g.) 1 minutes“. In 0.3.1 this feature is working fine, but in svn, guayadeque starts to play the first track in the playlist instead the third (in my example). Summed up: the feature „restore position ...“ (of the last played track – I suppose) is not working correct in 0.3.4.
Hope, I'm better understandable now.
Garak

hasufell
Posts: 30
Joined: Mon Nov 28, 2011 3:53 pm

New Guayadeque with Collections Support now up in svn

Post by hasufell » Tue Dec 20, 2011 11:18 pm

I just tried myself, same here.

If I deactivate the "restore position" option again guayadeque will not jump back to the first track anymore.

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

New Guayadeque with Collections Support now up in svn

Post by anonbeat » Wed Dec 21, 2011 1:12 am

I confirm this bug and will fix it asap. Working in cue support atm

Garak
Posts: 11
Joined: Sun Jul 24, 2011 5:06 am

New Guayadeque with Collections Support now up in svn

Post by Garak » Wed Dec 21, 2011 7:19 am

Thanks a lot.

jonas61
Posts: 2
Joined: Tue Jun 14, 2011 10:19 am

New Guayadeque with Collections Support now up in svn

Post by jonas61 » Mon Jan 09, 2012 1:50 pm

Hello,
great thing to have more than one library. Just one issue:
If the libraries are on different volumes and one volume is not physically connected, the
option "random play if Playlist has less then 3 titles" should be deactivated. Otherwise guayadeque searches new songs also in the not connected library and uses 50% of processor power and is not useable till end of search (takes a long time when library consist of 130k tracks, so killing and restart guayadeque is faster). Any chance for a workaround? Thanks for your work!

lusich
Posts: 37
Joined: Fri Jul 15, 2011 5:41 pm

New Guayadeque with Collections Support now up in svn

Post by lusich » Tue Jan 24, 2012 7:15 pm

I tried the latest natty1 svn (I think it was 1755) a couple of days ago and I noticed a few bugs, as compared to the standard non-SVN stable package (0.3.1-1639).

1. when I imported my library, some of the songs (even though they were from the same album) were not imported correctly -- the tags on these few songs were showing incorrect information. I then used easyTag to "correct" the tags, but Guayadeque still wouldn't recognize the new tags even after rescanning the library. These were both flac and mp3 files.

2. Some of the album covers had to be imported manually

3. The "Edit songs" functionality was buggy. It seemed to only work when right-clicking on an "album" selection, but not when clicking on the "track" selection itself. When clicking it on a "track" selection -- nothing would happen.

4. "Copy To" functionality kept showing up randomly when I would click on a song or album to select it.

Hope this is useful. I now switched back to build 1639.

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

New Guayadeque with Collections Support now up in svn

Post by anonbeat » Wed Jan 25, 2012 12:16 am

lusich wrote:I tried the latest natty1 svn (I think it was 1755) a couple of days ago and I noticed a few bugs, as compared to the standard non-SVN stable package (0.3.1-1639).

1. when I imported my library, some of the songs (even though they were from the same album) were not imported correctly -- the tags on these few songs were showing incorrect information. I then used easyTag to "correct" the tags, but Guayadeque still wouldn't recognize the new tags even after rescanning the library. These were both flac and mp3 files.

2. Some of the album covers had to be imported manually

3. The "Edit songs" functionality was buggy. It seemed to only work when right-clicking on an "album" selection, but not when clicking on the "track" selection itself. When clicking it on a "track" selection -- nothing would happen.

4. "Copy To" functionality kept showing up randomly when I would click on a song or album to select it.

Hope this is useful. I now switched back to build 1639.
1. Can you send me one or two sample files to my email so I can check what went wrong please ?

2. Why? had the word to detect that covers correctly set and not picked ? can you explain more details please ?

3. Can you give me more details please ? where you using fron a regular collection? a portable device ? iPod collection? Maybe the files was from a cue file ? was you using the library view ?

4. Again please give me more details on how to reproduce this problem. Copy to functionality shows up in many sites and can be called with many params and to do many things.

Thanks for your help

tamalet
Posts: 490
Joined: Fri Sep 24, 2010 4:34 am

New Guayadeque with Collections Support now up in svn

Post by tamalet » Wed Jan 25, 2012 5:37 am

1. Make sure that you are saving tags in ID3v2.4 (and not in v2.3).

4. Make sure that your shortcuts did not get mess up when updating.

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

New Guayadeque with Collections Support now up in svn

Post by anonbeat » Wed Jan 25, 2012 5:38 am

@tamalet: 4. shortcuts Update problem was fixed already

Post Reply