Missing file in rev 1544?

Use this category to discuss anything related to the development of Guayadeque.
Post Reply
bhm
Posts: 4
Joined: Tue Mar 22, 2011 6:52 am

Missing file in rev 1544?

Post by bhm » Tue Mar 22, 2011 6:58 am

Just downloaded 1544 rev from svn. Seems there's file missing I guess.

Code: Select all

guayadeque-svn/src/PlayerPanel.h:38: fatal error: wx/aui/aui.h: No such file or directory
compilation terminated.
make[2]: *** [src/CMakeFiles/guayadeque.dir/AlListBox.o] Error 1
make[1]: *** [src/CMakeFiles/guayadeque.dir/all] Error 2
make: *** [all] Error 2
Or is it mistake on my end?

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

Missing file in rev 1544?

Post by anonbeat » Tue Mar 22, 2011 7:15 am

You should have the file at /usr/include/wx-2.8/wx/aui/aui.h

bhm
Posts: 4
Joined: Tue Mar 22, 2011 6:52 am

Missing file in rev 1544?

Post by bhm » Tue Mar 22, 2011 7:46 am

File's there. I'm on Maverick.
Some switch to pass or change maybe?

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

Missing file in rev 1544?

Post by anonbeat » Tue Mar 22, 2011 9:07 am

run this commands and let me know please

make clean
./build

In case something went wrong so the make files are rebuilt

bhm
Posts: 4
Joined: Tue Mar 22, 2011 6:52 am

Missing file in rev 1544?

Post by bhm » Tue Mar 22, 2011 1:47 pm

[ 0%] Building CXX object src/CMakeFiles/guayadeque.dir/AlListBox.o
In file included from ~/guayadeque-svn/src/AlbumBrowser.h:27,
from ~/guayadeque-svn/src/MainFrame.h:24,
from ~/guayadeque-svn/src/AlListBox.cpp:28:
~/guayadeque-svn/src/PlayerPanel.h:38: fatal error: wx/aui/aui.h: No such file or directory
compilation terminated.
make[2]: *** [src/CMakeFiles/guayadeque.dir/AlListBox.o] Error 1
make[1]: *** [src/CMakeFiles/guayadeque.dir/all] Error 2
make: *** [all] Error 2


Same story.

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

Missing file in rev 1544?

Post by anonbeat » Tue Mar 22, 2011 2:02 pm

Can you send me by email the complete build log please ?
anonbeat at gmail dot com

Thanks

bhm
Posts: 4
Joined: Tue Mar 22, 2011 6:52 am

Missing file in rev 1544?

Post by bhm » Tue Mar 22, 2011 4:28 pm

I figured it out.
For some reason version 2.6 not 2.8 wxWidgets was used as default.

This will allow to change it back to proper.
sudo update-alternatives --config wx-config

Post Reply