Segfault and other glitches

Use this category to discuss anything related to the development of Guayadeque.
l300lvl
Posts: 226
Joined: Sun Mar 06, 2011 12:21 pm

Segfault and other glitches

Post by l300lvl » Sun Mar 13, 2011 11:57 pm

Okay, maybe I was wrong again, heh.

After more extensive testing, it would seem it wasn't bluetooth at all, but instead something to due with the lyrics searching/saving. I haven't narrowed it down to anything specifically, but I unchecked all of the lyrics sources and unselected follow player, and all is well now, no lag, with or without bluetooth.

Using gdb helped me determine it was the lyrics, as it doesn't lag when you first try to use the Songs Editor, unless it's searching for lyrics, or unless you accidentally click the lyrics tab, steps I took were:

Open Guayadeque with lyrics options set to default, disabled follow player, played a song, and began using Songs Editor. All seemed fine, then I clicked the lyrics tab in the main window and enabled follow player, and went back to editing. All of this is with it set to save to file, if that helps. Then in Songs Editor it seemed fine at first, but then I click the lyrics tab once, and it lagged terribly, so I closed songs editor and went back into it.

Once back in editor, things were ok for about a minute, then it starts lagging again and it didnt make any sense, so I look in gdb and at the exact time it starts lagging, it had begun searching for lyrics, yes a new song was started but I don't think that would make it continue to lag, it would just lag once and be fine again.

So I closed it out and went and unchecked all lyrics sources, disabled follow player, etc, all is well now. Excellent player, and well worth investing more time in, Thank you for the support so far!

Maybe an option to remove the lyrics tab from Songs Editor, and/or a quick select option to disable lyrics searching altogether, from the main lyrics tab?

l300lvl
Posts: 226
Joined: Sun Mar 06, 2011 12:21 pm

Segfault and other glitches

Post by l300lvl » Mon Mar 14, 2011 12:17 am

Again: I still aren't sure, I don't know anymore, it still seems to lag a bit? Maybe its however it connects to servers? It definitely doesn't make any sense to me, but I'm not a programmer...

I thought for sure it was to due with the lyrics, but since you said this is only an issue on my end so far, perhaps my machine itself is laggy. I have heard how low end atoms actually are in terms of manufacturing, so maybe I should find a way to test on a live cd, or another machine.

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

Segfault and other glitches

Post by anonbeat » Mon Mar 14, 2011 12:43 am

As I told you I do testings on a Pentium IV 3Ghz as a low end machine and it seems to be far from what you are getting. No lag at all but the CPU usage goes hight for a short period of time because it need to refresh the comboboxes.
Im trying to optimize it even more thought.

Thanks for your help

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

Segfault and other glitches

Post by anonbeat » Mon Mar 14, 2011 12:53 am

Please can you try with svn revision 1523 and let me know if its any better ?

Thanks for your help

l300lvl
Posts: 226
Joined: Sun Mar 06, 2011 12:21 pm

Segfault and other glitches

Post by l300lvl » Mon Mar 14, 2011 10:37 am

im not sure how to do specific revisions, i updated to 1525, is that ok?

it seems to be a lot more responsive so far if that means anything, i played with it for a bit and it seems to lag once or twice but only occasionally so its nothing like it was

thanks again

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

Segfault and other glitches

Post by anonbeat » Mon Mar 14, 2011 10:50 am

yes 1525 is ok too.

Thanks for report it back.

tamalet
Posts: 490
Joined: Fri Sep 24, 2010 4:34 am

Segfault and other glitches

Post by tamalet » Mon Mar 14, 2011 10:52 am

That should be OK.
In case you really want some specific revision you can also do it. I don't have svn here to try it, but I guess it'ssvn co -r revision_number

l300lvl
Posts: 226
Joined: Sun Mar 06, 2011 12:21 pm

Segfault and other glitches

Post by l300lvl » Mon Mar 14, 2011 12:17 pm

excellent, thank you again for the awesome support and app, it really is the best so far, i even went as far as installing the other top 3 and they just dont show promise in my opinion, ill be sure to post back from time to time

tamalet: thank you, i did man svn finally and that seems to be what i needed, i wont forget it :D

another question, or more of a suggestion actually, maybe i should open a new topic for it, but is it possible to have an option to show only the file name in Songs Editor and not the full path of the song, on the left side? or perhaps only show file name when clicking Edit Album Songs and then show full path when clicking Edit Songs?

camaron
Posts: 462
Joined: Sat Sep 25, 2010 3:38 am

Segfault and other glitches

Post by camaron » Mon Mar 14, 2011 12:23 pm

l300lvl wrote: is it possible to have an option to show only the file name in Songs Editor and not the full path of the song, on the left side? or perhaps only show file name when clicking Edit Album Songs and then show full path when clicking Edit Songs?
This is a very good idea. Very often it is necessary to scroll sideways to actually see the name of the file but I don't see much the point in seeing the full path. Totally agree with it :)

camaron
Posts: 462
Joined: Sat Sep 25, 2010 3:38 am

Segfault and other glitches

Post by camaron » Mon Mar 14, 2011 12:31 pm

l300lvl wrote:i even went as far as installing the other top 3 and they just dont show promise in my opinion
I think we've all installed the top 3 as you call them (and a few others) and realized just the same as you: what's all the fuzz about?

Post Reply