Segfault and other glitches

Use this category to discuss anything related to the development of Guayadeque.
l300lvl
Posts: 226
Joined: Sun Mar 06, 2011 12:21 pm

Segfault and other glitches

Post by l300lvl » Sun Mar 06, 2011 12:53 pm

been using Guayadeque for a minute now, and was having some problems with stable like not being able to update library or it not saving the layout even if I saved it, so I went for svn.

Been using svn for about 2 weeks now, just recompiled using these instructions so I could try and benefit the project in the long run as I love this player. http://guayadeque.org/forums/index.php? ... /backtrace

First issue, saves the layout now, but before I recompiled it wasn't saving the 'columns' where the song list is, at all, well it's saving them after recompiling I guess so thats not an issue so much now. Atm it also won't let me run it from the menu though, but thats okay since I'm only running svn in debug to solve problems, I'd rather always run it the hard way from cli for now. On to the segfault

First segfault I got since running in dbg, just happened so I signed up here. From what I remember it happened when updating tags using the built in musicbrainz, a track was playing and I tried to update an album, then when it crashed the process remained and the icon in the system tray was still there. I just went ahead and killed it so I could continue to run.


01:12:26 PM: OnMediaPosition... 117105 - 177031 1299417003 0
01:12:27 PM: OnMediaPosition... 118104 - 177031 1299417003 0
01:12:28 PM: guMainFrame::DoLibraryClean
[New Thread 0x7fffe6a0d700 (LWP 689)]
01:12:28 PM: OnMediaPosition... 119097 - 177031 1299417003 0

Program received signal SIGSEGV, Segmentation fault.
0x0000000000611ddb in operator[] (this=0x1245800, row=,
col=0) at /home/l300lvl/guayadeque/src/DbLibrary.h:127
127 WX_DECLARE_OBJARRAY(guTrack, guTrackArray);
(gdb) bt
#0 0x0000000000611ddb in operator[] (this=0x1245800,
row=, col=0)
at /home/l300lvl/guayadeque/src/DbLibrary.h:127
#1 guSoListBox::OnGetItemText (this=0x1245800, row=,
col=0) at /home/l300lvl/guayadeque/src/SoListBox.cpp:129
#2 0x000000000068afcf in guListViewClient::DoDrawItem (this=0x1094000,
dc=..., rect=, row=12, col=0)
at /home/l300lvl/guayadeque/src/ListView.cpp:918
#3 0x0000000000686ddc in guListViewClient::OnDrawItem (this=0x1094000,
dc=..., rect=, n=)
at /home/l300lvl/guayadeque/src/ListView.cpp:952
#4 0x0000000000687a54 in guListViewClient::OnPaint (this=0x1094000,
event=)
at /home/l300lvl/guayadeque/src/ListView.cpp:893
#5 0x00007ffff7b6e310 in wxEvtHandler::ProcessEventIfMatches(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&) () from /usr/lib/libwx_baseu-2.8.so.0
#6 0x00007ffff7b6f2d4 in wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*) () from /usr/lib/libwx_baseu-2.8.so.0
#7 0x00007ffff7b6f3b7 in wxEvtHandler::ProcessEvent(wxEvent&) ()
from /usr/lib/libwx_baseu-2.8.so.0
#8 0x00007ffff7669f05 in wxWindow::GtkSendPaintEvents() ()
from /usr/lib/libwx_gtk2u_core-2.8.so.0
#9 0x00007ffff766a408 in ?? () from /usr/lib/libwx_gtk2u_core-2.8.so.0
---Type to continue, or q to quit---
#10 0x00007ffff22789d8 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
Cannot access memory at address 0x7fffffffd498
(gdb) run
The program being debugged has been started already.
Start it from the beginning? (y or n)

should i hit y or n when I get that message^ start from the beginning or not? I just closed out terminal this time to start gdb again but whats the best method?

this isnt the largest collection if that matters at all just under 18k tracks, anything I should post to help figure this out?

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

Segfault and other glitches

Post by anonbeat » Sun Mar 06, 2011 2:39 pm

can you next time do bt from the dbg prompt when you get a segfault ?

Can you give me details on what distro are you using ? also what kernel? 32bits or amd64 ?

Thanks for your help

l300lvl
Posts: 226
Joined: Sun Mar 06, 2011 12:21 pm

Segfault and other glitches

Post by l300lvl » Sun Mar 06, 2011 5:46 pm

i typed in bt right from (gdb) and hit enter, i still have terminal open from when it happened if youd like more output but i think i gave everything it gave me

edit- yeah i double checked and i have closed that terminal, but i did run it right after the segfault, the (gbd) prompt had reappeared, i did find that rather odd even though the process was still running and then when i tried to end process it was 'zombie' so i went ahead and did killall -9 guayadeque

running 64 bit, linux Mint 10 Julia(ubuntu Maverick Meerkat), kernel 2.6.35-25.45 Linux 2.6.35-25-generic [x86_64/1.67GHz/SMP]

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

Segfault and other glitches

Post by anonbeat » Mon Mar 07, 2011 12:06 am

the debug information dont match the latest source code. Can you please be sure you are running the latest svn version ?

Thanks for your help

l300lvl
Posts: 226
Joined: Sun Mar 06, 2011 12:21 pm

Segfault and other glitches

Post by l300lvl » Mon Mar 07, 2011 10:10 am

0.2.8-1493 is what i get when i run it

synaptic shows 0.2.9~maverick as the Installed Version the package is just guayadeque and
the package guayadeque-svn is unchecked, does that mean svn isnt installed? how can i install it and remove the normal version, and keep my db?

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

Segfault and other glitches

Post by anonbeat » Mon Mar 07, 2011 11:09 am

with this
sudo add-apt-repository ppa:anonbeat/guayadeque
sudo apt-get update
sudo apt-get remove guayadeque
sudo apt-get install guayadeque-svn

l300lvl
Posts: 226
Joined: Sun Mar 06, 2011 12:21 pm

Segfault and other glitches

Post by l300lvl » Mon Mar 07, 2011 1:11 pm

thanks, i realized the issue was, i had svn installed, but I had to re-read the part about 'svn update' found here: http://guayadeque.org/forums/index.php? ... InstallSVN

currently installed is 0.3.0-1517

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

Segfault and other glitches

Post by anonbeat » Mon Mar 07, 2011 1:12 pm

Can you try to get the segfault using this version from gdb ?
Please compile it using ./buildd instead of ./build so debug info is added

Thanks for your help

l300lvl
Posts: 226
Joined: Sun Mar 06, 2011 12:21 pm

Segfault and other glitches

Post by l300lvl » Tue Mar 08, 2011 10:50 pm

Awesome, sorry I didnt reply back sooner I was lazy I admit.

That seems to have solved it so far, and I cant be sure but musicbrainz seems to be a bit more responsive as well. If I ever get another segfault I will surely post it here.

As for the musicbrainz issue, it's a bit slow even when not playing a song and trying to update, is there anything that can be done about it? Maybe you're already aware of it but it's also had me curious. What I mean by slow is, moving from one song to the next in the list, copying fields to all tracks, etc. Searching isn't slow, but getting to the actual point that you can click the search button is. Does that make sense?

camaron
Posts: 462
Joined: Sat Sep 25, 2010 3:38 am

Segfault and other glitches

Post by camaron » Wed Mar 09, 2011 12:48 am

i300lvl, any field in the songs (tags) editor has de option to apply the chosen field to all the selected tracks at once. It is the icons on the left that look like two sheets of paper. Is this how it is slow? Are you editing track by track?

Post Reply