crash when unmounting camera

Use this category to discuss anything related to the development of Guayadeque.
Post Reply
rotwang888
Posts: 55
Joined: Thu Oct 07, 2010 1:29 pm

crash when unmounting camera

Post by rotwang888 » Fri Jan 07, 2011 9:21 pm

I'm not sure if this is caused by the same gvfs problem that was already reported with mounting Windows shares, but Guayadeque crashes every time I unmount my camera. Most recently with 1417. The only output was "07:35:27 PM: OnMediaPosition... 27046 - 173413 1294428895 0
07:35:28 PM: Mount Removed...
07:35:28 PM: Mount Removed..."

A while back on a previous version I had the same crash, but with a little more output...

"07:14:03 PM: OnMediaPosition... 722173 - 1393341 1293735716 0
07:14:04 PM: Volume Removed...
07:14:04 PM: Mount Removed...
07:14:04 PM: guMainFrame::OnVolumeMonitorUpdated
07:14:04 PM: It was unmounted...
07:14:04 PM: ... 'DISK1'
07:14:04 PM: ... 'multimedia'
07:14:04 PM: ... 'storage'
07:14:04 PM: Searching for basecmd 14000
07:14:04 PM: Searching for basecmd 14020
07:14:04 PM: Searching for basecmd 14040

Program received signal SIGSEGV, Segmentation fault.
type_check_is_value_type_U (type=) at gtype.c:4076
4076 if (node->data && NODE_REFCOUNT (node) > 0 &&
Missing separate debuginfos, use: debuginfo-install libcroco-0.6.2-4.fc13.x86_64 libgsf-1.14.18-1.fc13.x86_64 librsvg2-2.26.3-1.fc13.x86_64"

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

crash when unmounting camera

Post by anonbeat » Tue Jan 11, 2011 2:42 am

Can you do a backtrace to find where the problem comes from ?

Thanks for your help

rotwang888
Posts: 55
Joined: Thu Oct 07, 2010 1:29 pm

crash when unmounting camera

Post by rotwang888 » Wed Jan 12, 2011 12:27 pm

I wasn't able to compile with ./buildd on the versions I was running when it happened, but the next time I can I will.

rotwang888
Posts: 55
Joined: Thu Oct 07, 2010 1:29 pm

crash when unmounting camera

Post by rotwang888 » Wed Jan 12, 2011 12:55 pm

Ok, ./buildd worked on 1431. I unmounted the camera from nautilus and guayadeque did not crash (it always has in the past). I mounted the camera again and turned the camera off, which did crash the program, but I wasn't able to get a backtrace. Here is the output-

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff07d74a4 in g_mount_info_equal () from /usr/lib64/libgvfscommon.so.0
Missing separate debuginfos, use: debuginfo-install ORBit2-2.14.18-1.fc13.x86_64 PackageKit-gtk-module-0.6.6-2.fc13.x86_64 SDL-1.2.14-8.fc13.x86_64 cyrus-sasl-lib-2.1.23-11.fc13.x86_64 dbus-glib-0.86-4.fc13.x86_64 expat-2.0.1-10.fc13.x86_64 flac-1.2.1-6.fc12.x86_64 freetype-2.3.11-7.fc13.x86_64 gamin-0.1.10-7.fc13.x86_64 glibc-2.12.2-1.x86_64 gnutls-2.8.6-2.fc13.x86_64 gstreamer-0.10.30-1.fc13.x86_64 gstreamer-plugins-base-0.10.30-1.fc13.x86_64 gstreamer-plugins-good-0.10.25-1.fc13.x86_64 gstreamer-plugins-ugly-0.10.16-1.fc13.x86_64 gtk2-engines-2.20.1-1.fc13.x86_64 gvfs-1.6.2-1.fc13.x86_64 ibus-gtk-1.3.9-2.fc13.x86_64 ibus-libs-1.3.9-2.fc13.x86_64 keyutils-libs-1.2-6.fc12.x86_64 krb5-libs-1.7.1-16.fc13.x86_64 libXau-1.0.5-1.fc12.x86_64 libXcomposite-0.4.1-2.fc13.x86_64 libXcursor-1.1.10-4.fc13.x86_64 libXdamage-1.1.2-2.fc13.x86_64 libXfixes-4.0.4-2.fc13.x86_64 libXi-1.3.2-1.fc13.x86_64 libXinerama-1.1-2.fc13.x86_64 libXrandr-1.3.0-5.fc13.x86_64 libXtst-1.0.99.2-3.fc12.x86_64 libXxf86vm-1.1.0-1.fc13.x86_64 libasyncns-0.8-1.fc13.x86_64 libcanberra-0.24-1.fc13.x86_64 libcanberra-gtk2-0.24-1.fc13.x86_64 libcom_err-1.41.10-7.fc13.x86_64 libcurl-7.20.1-5.fc13.x86_64 libgcc-4.4.5-2.fc13.x86_64 libgcrypt-1.4.5-4.fc13.x86_64 libgpg-error-1.7-1.fc13.x86_64 libgpod-0.8.0-1.fc13.x86_64 libid3tag-0.15.1b-10.fc13.x86_64 libidn-1.16-1.fc13.x86_64 libimobiledevice-1.0.4-1.fc13.x86_64 libjpeg-6b-46.fc12.x86_64 libmad-0.15.1b-13.fc12.x86_64 libogg-1.2.0-1.fc13.x86_64 libplist-1.3-1.fc13.x86_64 libpng-1.2.44-1.fc13.x86_64 libselinux-2.0.94-2.fc13.x86_64 libsndfile-1.0.20-5.fc13.x86_64 libssh2-1.2.4-1.fc13.x86_64 libstdc++-4.4.5-2.fc13.x86_64 libtasn1-2.4-2.fc13.x86_64 libtdb-1.2.1-2.fc13.x86_64 libtiff-3.9.4-1.fc13.x86_64 libtool-ltdl-2.2.6-20.fc13.x86_64 libudev-153-5.fc13.x86_64 libuuid-2.17.2-9.fc13.x86_64 libvorbis-1.3.1-1.fc13.x86_64 libxcb-1.5-1.fc13.x86_64 nspr-4.8.6-1.fc13.x86_64 nss-3.12.8-2.fc13.x86_64 nss-mdns-0.10-8.fc12.x86_64 nss-softokn-freebl-3.12.8-1.fc13.x86_64 nss-util-3.12.8-1.fc13.x86_64 openldap-2.4.21-10.fc13.x86_64 openssl-1.0.0c-1.fc13.x86_64 orc-0.4.10-1.fc13.x86_64 pixman-0.18.0-1.fc13.x86_64 pulseaudio-libs-0.9.21-7.fc13.x86_64 sqlite-3.6.22-1.fc13.x86_64 taglib-1.6.3-1.fc13.x86_64 tcp_wrappers-libs-7.6-59.fc13.x86_64 usbmuxd-1.0.6-1.fc13.x86_64 wxBase-2.8.11-2.fc13.x86_64 wxGTK-2.8.11-2.fc13.x86_64 zlib-1.2.3-23.fc12.x86_64
(gdb) bt
#0 0x00007ffff07d74a4 in g_mount_info_equal ()
from /usr/lib64/libgvfscommon.so.0
Cannot access memory at address 0x7fffffffd958

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

crash when unmounting camera

Post by anonbeat » Wed Jan 12, 2011 2:12 pm

This looks like the gvfs bug reported by others aswell

Thanks for your help

Post Reply