Portable device support questions, bug reports, etc HERE

Use this category to discuss anything related to the development of Guayadeque.
wilk
Posts: 1
Joined: Tue Aug 16, 2011 8:52 am

Portable device support questions, bug reports, etc HERE

Post by wilk » Thu Aug 18, 2011 9:34 am

I can't copy tracks to my mp3 player when there is a space in the name of the file. I remember noticing this bug before but I thought it had been fixed. Here is the error message :


19:31:38: Copy /srv/multimedia/musique/Bon_Iver/Bon_Iver,_Bon_Iver/Bon_Iver,_Bon_Iver-01-Perth.ogg =>> /media/MICROSD8G/MUSIC/Bon Iver /Bon Iver, Bon Iver/Bon Iver, Bon Iver - 01 - Perth.ogg
19:31:38: Error: Directory '/media/MICROSD8G/MUSIC/Bon Iver ' couldn't be created (error 22: Argument invalide)

kungfool
Posts: 3
Joined: Tue May 24, 2011 1:54 pm

Portable device support questions, bug reports, etc HERE

Post by kungfool » Wed Sep 07, 2011 11:43 am

Is there a way to manually add a portable device? I have an older video ipod that I can mount and load files on to using gtkpod, but for some odd reason guayadeque does not see it.

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

Portable device support questions, bug reports, etc HERE

Post by anonbeat » Wed Sep 07, 2011 1:27 pm

If linux dont mount the device guayadeque cant see it. Please check why its not mounted in linux.

Thanks for your help

kungfool
Posts: 3
Joined: Tue May 24, 2011 1:54 pm

Portable device support questions, bug reports, etc HERE

Post by kungfool » Thu Sep 08, 2011 8:02 am

Sorry my last post might have been a little confusing. I'm using arch linux and I can mount the ipod and use it with other programs, but for some odd reason I can not use guayadeque to transfer to either of my ipods.

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

Portable device support questions, bug reports, etc HERE

Post by anonbeat » Thu Sep 08, 2011 8:07 am

Have you checked my video showing how to transfer tracks to the ipod ?
http://www.youtube.com/watch?v=wknt5ilIZrY

Thanks for your help

asyler
Posts: 2
Joined: Mon Jan 24, 2011 3:02 am

Portable device support questions, bug reports, etc HERE

Post by asyler » Fri Sep 09, 2011 11:55 am

Hello my dear friend, anonbeat!
How can I scrobble tracks listened on my iPod via Guayadeque on last.fm?

asyler
Posts: 2
Joined: Mon Jan 24, 2011 3:02 am

Portable device support questions, bug reports, etc HERE

Post by asyler » Sat Sep 10, 2011 1:45 am

One more question.
Err, I can't upload file, so, here it is: https://picasaweb.google.com/lh/photo/V ... directlink
Look at the screenshot. In current playlist is album from iPod.
And I'm trying to change song rating.
If I click stars highlighted black nothing happens.
Only if I click stars highlighted red rating changes, but only in playlist.
Actually, I can change rating via right panel (iPod:Library).

So, why noting happens when I was clicking stars highlighted black?
And is the iPod:Library only one way to change rating on device?

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

Portable device support questions, bug reports, etc HERE

Post by anonbeat » Tue Sep 20, 2011 1:57 pm

asyler wrote:One more question.
Err, I can't upload file, so, here it is: https://picasaweb.google.com/lh/photo/V ... directlink
Look at the screenshot. In current playlist is album from iPod.
And I'm trying to change song rating.
If I click stars highlighted black nothing happens.
Only if I click stars highlighted red rating changes, but only in playlist.
Actually, I can change rating via right panel (iPod:Library).

So, why noting happens when I was clicking stars highlighted black?
And is the iPod:Library only one way to change rating on device?
Thanks for your bug report. I will try to fix this asap.

About scrobble listened tracks in iPod its more or less the same problem as the one you mentioned now. I will try to get them fixed soon

Thanks for your help

Thanks

Kadai
Posts: 2
Joined: Sat Aug 27, 2011 10:30 pm

Portable device support questions, bug reports, etc HERE

Post by Kadai » Sat Oct 15, 2011 11:29 pm

I'm having an weird issue...
With an iPod nano 4th gen, the system is able to see the device, even other software sees it, but not Guayadeque... at least not where it is mounted.

My system is a fresh install of Kubuntu 11.10, with Guayadeque compiled from source (with debugs symbols with libgpod detected) and everything needed to use the ipod.

But then still, Guayadeque does not see it (it is not listed on the "Portable Devices" list), but it is aware that a device got mounted or removed:

02:02:39 AM: Mount Removed...
02:02:58 AM: Mount Added...
02:02:58 AM: mount without volume?

I always see those messages, but nothing else that might help me to discover what is preventing guayadeque to see the ipod... even I checked on /usr/lib to see if they where the libgpod.so* files, and they were... so then I'm running out of ideas.

Anyone might know how to debug this or troubleshot it?

Here is what ./buildd tells me when getting ready to compile (I had all the dependencies installed as like show in the Compile from source page on here)

-- checking for module 'gstreamer-0.10'
-- found gstreamer-0.10, version 0.10.35
-- checking for module 'sqlite3'
-- found sqlite3, version 3.7.7
-- checking for module 'libcurl'
-- found libcurl, version 7.21.6
-- checking for module 'taglib>=1.6.1'
-- found taglib, version 1.7.0
-- checking for module 'dbus-1'
-- found dbus-1, version 1.4.14
-- checking for module 'flac'
-- found flac, version 1.2.1
-- checking for module 'gio-2.0'
-- found gio-2.0, version 2.30.0
-- checking for module 'libgpod-1.0'
-- found libgpod-1.0, version 0.8.0
-- checking for module 'indicate'
-- package 'indicate' not found
libindicate library not found! No sound menu support!!
-- checking for module 'appindicator-0.1'
-- package 'appindicator-0.1' not found
-- Found Subversion: /usr/bin/svn (found version "1.6.12")
Current revision is 1658


Thanks in advance.

stephaneeybert
Posts: 1
Joined: Sat Nov 19, 2011 11:45 am

Portable device support questions, bug reports, etc HERE

Post by stephaneeybert » Sat Nov 19, 2011 11:54 am

I get a crash when trying to copy the music from my library to my iPod Touch 3.

I also systematically got a crash when trying to download the cover of one specific album, but all the other albums of my library could have their covers downloaded fine by Guayadeque.

I'm using Guayadeque 0.3.4

Post Reply