Segfaul (related to mount??)

Use this category to discuss anything related to the development of Guayadeque.
Post Reply
mekanix
Posts: 210
Joined: Wed Sep 29, 2010 11:20 pm

Segfaul (related to mount??)

Post by mekanix » Tue Dec 14, 2010 1:55 am

Hi Anonbeat!

guayadeque randomly exit while is not playing... It happened to me that sometimes after coming back to my pc from a break, I founded guayadeque closed, after the restart, the current play queue were not updated with the last songs I was listening to...

today I builded guayadeque to make a backtrace



Starting program: /home/MNEGRI/rgonelladiaza/Programs/SOURCES/devs/guayadeque/guayadeque
[Thread debugging using libthread_db enabled]
08:32:53: Initialized locale ( it_IT )
08:32:53: Library Db Version 21
08:32:53: Library Paths:
08:32:53: /media/LACIE/Musica/
08:32:53: Mount Added...
08:32:53: Mount Path: /media/LACIE/
08:32:53: IconStr: '. GThemedIcon drive-harddisk-usb drive-harddisk drive'
08:32:53: 0000628F
08:32:53: RefreshBitmaps 0 2
08:32:53: RefreshBitmaps 0 2
08:32:53: RefreshBitmaps 1256 2
08:32:53: RefreshBitmaps 1256 2
08:32:53: Id: 4 Pane: PlayerVumeters Show:1 Flags:0000628F
08:32:53: guLocationTreeCtrl::ReloadItems
08:32:53: ... 'LACIE'
08:32:53: Searching for basecmd 14000
08:32:53: RefreshBitmaps 1119 2
08:32:53: RefreshBitmaps 1119 2
08:32:53: Id: 8192 Pane: MainSources Show:1 Flags:0000628F
08:32:53: Changed image to 0 ''
08:32:53: NewSize: 130
08:32:53: Updating Size: 130
08:32:53: Id: 16384 Pane: MainShowCover Show:1 Flags:0000628F
08:32:53: ... 'LACIE'
08:32:53: Searching for basecmd 14000
[New Thread 0x7fffe8850700 (LWP 4107)]
[Thread 0x7fffe8850700 (LWP 4107) exited]
08:33:04: NewSize: 196
08:33:04: Updating Size: 196
08:33:04: RefreshBitmaps 166 22
08:33:04: RefreshBitmaps 166 22
[New Thread 0x7fffe8850700 (LWP 4108)]
[Thread 0x7fffe8850700 (LWP 4108) exited]
08:33:04: guLocationTreeCtrl::ReloadItems
08:33:04: ... 'LACIE'
08:33:04: Searching for basecmd 14000
[New Thread 0x7fffe8850700 (LWP 4109)]
08:33:04: NewSize: 196
08:33:04: RefreshBitmaps 20 20
08:33:04: RefreshBitmaps 20 20
08:33:04: NewSize: 196
08:33:04: NewSize: 196
08:33:05: NewSize: 196
08:33:05: NewSize: 196
08:33:05: Database updating started. 0
08:33:05: Updating the podcasts...
08:33:05: ... 'LACIE'
08:33:05: Searching for basecmd 14000
[New Thread 0x7fffe3abb700 (LWP 4111)]
08:33:05: Doing Library Update in /media/LACIE/Musica/
[New Thread 0x7fffe32ba700 (LWP 4112)]
[Thread 0x7fffe32ba700 (LWP 4112) exited]
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Properties::read() -- Page headers were invalid.
08:33:11: Setting new cover '/media/LACIE/Musica/Atheist/Jupiter/cover.jpg'
[Thread 0x7fffe3abb700 (LWP 4111) exited]
08:33:11: guMainFrame::DoLibraryClean
[New Thread 0x7fffe3abb700 (LWP 4114)]
08:33:11: ReloadControls...0000041F
[Thread 0x7fffe3abb700 (LWP 4114) exited]
08:33:30: ... 'LACIE'
08:33:30: PanelActive: -1
08:33:33: NewSize: 196
08:33:37: ... 'LACIE'
08:33:37: PanelActive: -1
08:33:38: NewSize: 196
08:33:49: ... 'LACIE'
08:33:49: PanelActive: -1
08:33:51: NewSize: 196
08:33:52: ... 'LACIE'
08:33:52: PanelActive: -1
08:33:53: NewSize: 196
08:33:58: ... 'LACIE'
08:33:58: PanelActive: -1
08:34:00: NewSize: 196
[New Thread 0x7fffe3abb700 (LWP 4188)]
[Thread 0x7fffe3abb700 (LWP 4188) exited]
[New Thread 0x7fffe3abb700 (LWP 4859)]
[Thread 0x7fffe3abb700 (LWP 4859) exited]
09:06:21: Mount Added...
09:06:21: mount without volume?
[New Thread 0x7fffe3abb700 (LWP 5150)]
[Thread 0x7fffe3abb700 (LWP 5150) exited]

Program received signal SIGSEGV, Segmentation fault.
0x00007fffe9675da4 in g_mount_info_equal () from /usr/lib/libgvfscommon.so.0



The LACIE volume is my external hard disk, where I keep my library.

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

Segfaul (related to mount??)

Post by anonbeat » Tue Dec 14, 2010 3:48 am

could you please do a backtrace ? but for your info posted looks like a gvfs bug

Thanks for your help

Post Reply