Guayadeque stops after every track

General discussions
mekanix
Posts: 210
Joined: Wed Sep 29, 2010 11:20 pm

Guayadeque stops after every track

Post by mekanix » Tue Apr 22, 2014 1:17 am

Hi anonbeat! Sorry for the delay!

This is what I get after starting the first song

08:19:37: playlist active 0
08:19:37: playlist active 0
08:19:46: Track starts at 0 with length 189000
08:19:46: Now Playing track submit: Now ready to send...
08:19:46: StatusChanged( 0, 0, 0, 0 )
08:19:46: Trying to get url: http://lyrics.wikia.com/Annihilator:Reduced_to_Ash
08:19:46: Loged in to : http://post.audioscrobbler.com/
08:19:47: Found the lyrics from source: lyrics.wikia.com
08:20:02: StatusChanged( 2, 0, 0, 0 )


Then it stops, and after clicking Play again I get this

08:20:26: Adding track at 1398147626 played 189 mseconds
08:20:27: Adding pending update track '/media/LACIE/Musica/Annihilator/(1990) Never, Neverland/09 Reduced to Ash.mp3'
08:20:27: Track starts at 0 with length 214000
08:20:27: Now Playing track submit delayed. There are pending tracks to send...
08:20:27: Trying to get url: http://lyrics.wikia.com/Annihilator:I_Am_in_Command
08:20:27: Writing ratings and playcount...
08:20:27: Rating: -1 => 0
08:20:27: StatusChanged( 0, 0, 0, 0 )
08:20:27: Found the lyrics from source: lyrics.wikia.com
08:20:28: Now Playing track submit: Now ready to send...
08:20:52: StatusChanged( 2, 0, 0, 0 )


Hopes this helps

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

Guayadeque stops after every track

Post by anonbeat » Tue Apr 22, 2014 1:49 am

Could not reproduce the problem here... I have been changing crossfader settings and playing tracks in gapless and crossfading mode and all tracks plays fine...

mekanix
Posts: 210
Joined: Wed Sep 29, 2010 11:20 pm

Guayadeque stops after every track

Post by mekanix » Tue Apr 22, 2014 2:03 am

Could this problem being related to some different version of other important packages? I'm not a developer... so I don't know if this make sense.

User avatar
anonbeat
Posts: 1960
Joined: Thu Sep 16, 2010 9:47 pm

Guayadeque stops after every track

Post by anonbeat » Tue Apr 22, 2014 2:34 am

Please update to svn 1892. The problem should be fixed.

Sorry for the trouble.

mekanix
Posts: 210
Joined: Wed Sep 29, 2010 11:20 pm

Guayadeque stops after every track

Post by mekanix » Tue Apr 22, 2014 3:57 am

Hi Anonbeat!!! version 1892 works perfectly!!!! Thanks very much!!!!

kinggo
Posts: 242
Joined: Thu Feb 09, 2012 5:54 am

Guayadeque stops after every track

Post by kinggo » Tue Apr 22, 2014 9:26 am

Yes, it works now.

siddharthasahu
Posts: 8
Joined: Tue Jan 24, 2012 1:54 pm

Guayadeque stops after every track

Post by siddharthasahu » Sat Jul 26, 2014 1:47 am

Hi Anonbeat, r1892 seems to be causing problems for me. If crossfading is on, guayadeque crashes on track change.

siddharthasahu
Posts: 8
Joined: Tue Jan 24, 2012 1:54 pm

Guayadeque stops after every track

Post by siddharthasahu » Sat Jul 26, 2014 1:58 am

Also, here is a backtrace. Hope it helps:
(gdb) bt
#0 0x0000000000000000 in ?? ()
#1 0x00000000006ada75 in guTimeLine::Stop (this=0xc8fcd0)
at /home/lfiles/dev/build/makepkg/guayadeque-svn/src/guayadeque/src/TimeLine.cpp:227
#2 0x000000000056480a in TimerUpdated (timeline=)
at /home/lfiles/dev/build/makepkg/guayadeque-svn/src/guayadeque/src/MediaCtrl.cpp:2593
#3 0x00007ffff6063483 in ?? () from /usr/lib/libglib-2.0.so.0
#4 0x00007ffff6062a65 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#5 0x00007ffff6062dc8 in ?? () from /usr/lib/libglib-2.0.so.0
#6 0x00007ffff606308a in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#7 0x00007ffff3672417 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#8 0x00007ffff766e0ea in wxEventLoop::Run() () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#9 0x00007ffff76e2fec in wxAppBase::MainLoop() () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#10 0x00007ffff7b14f7d in wxEntry(int&, wchar_t**) () from /usr/lib/libwx_baseu-2.8.so.0
#11 0x000000000049fd72 in main (argc=1, argv=)
at /home/lfiles/dev/build/makepkg/guayadeque-svn/src/guayadeque/src/MainApp.cpp:40

siddharthasahu
Posts: 8
Joined: Tue Jan 24, 2012 1:54 pm

Guayadeque stops after every track

Post by siddharthasahu » Sat Jul 26, 2014 2:27 am

Ok so it is happenning even with crossfading off.
r1890 works, but updating to r1893 leads to these crashes.
Let me know if you need anything else to debug this.
Thanks

kinggo
Posts: 242
Joined: Thu Feb 09, 2012 5:54 am

Guayadeque stops after every track

Post by kinggo » Sat Sep 27, 2014 2:36 pm

bump.....
Clean install 14.10, crossfading on...

(gdb) bt
#0 0x0000000000000000 in ?? ()
#1 0x00000000006b65f5 in guTimeLine::Stop (this=0x2ef1800)
at /home/mario/guayadeque/src/TimeLine.cpp:227
#2 0x00000000005656ba in TimerUpdated (timeline=)
at /home/mario/guayadeque/src/MediaCtrl.cpp:2593
#3 0x00007ffff602f5d3 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4 0x00007ffff602eb2d in g_main_context_dispatch ()
from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5 0x00007ffff602ef08 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6 0x00007ffff602f232 in g_main_loop_run ()
from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7 0x00007ffff34d9457 in gtk_main ()
from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#8 0x00007ffff763f6ba in wxEventLoop::Run() ()
from /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-2.8.so.0
#9 0x00007ffff76c4beb in wxAppBase::MainLoop() ()
from /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-2.8.so.0
#10 0x00007ffff7b0fd3a in wxEntry(int&, wchar_t**) ()
from /usr/lib/x86_64-linux-gnu/libwx_baseu-2.8.so.0
#11 0x000000000049aa12 in main (argc=1, argv=)
at /home/mario/guayadeque/src/MainApp.cpp:40
(gdb)

with crossfading off it plays fine

Post Reply