Latest 09-17-21 Lauchpad build of Guayadeque for 20.04LTS broken

General discussions
Post Reply
rizlaw
Posts: 11
Joined: Tue Jun 11, 2019 4:05 pm

Latest 09-17-21 Lauchpad build of Guayadeque for 20.04LTS broken

Post by rizlaw »

This morning, 9.17.21, I received an update of Guayadeque (0.4.6.r2216.5eed2ee) via Launchpad PPA. It installed, but when I ran it I received an error stating that a gstreamer plugin was missing. At the time I was attempting to play an mp3 soundtrack.
User avatar
anonbeat
Posts: 2026
Joined: Thu Sep 16, 2010 9:47 pm

Re: Latest 09-17-21 Lauchpad build of Guayadeque for 20.04LTS broken

Post by anonbeat »

Can you run it from console and let me know the output of the application in the terminal when the error happens?

Thanks for reporting it
BearManJim
Posts: 1
Joined: Fri Sep 17, 2021 9:55 pm

Re: Latest 09-17-21 Lauchpad build of Guayadeque for 20.04LTS broken

Post by BearManJim »

I don't experience the same error with this particular build although do see a Gstreamer related error sometimes in console when skipping tracks. Doesn't appear to cause an issue?

(guayadeque:55484): GStreamer-WARNING **: 23:09:31.918: Trying to set string on structure field 'owner', but string is not valid UTF-8. Please file a bug.

I do however experience a separate new repeatable issue with this version?

Whenever I stop a track (either using the stop button or via the shortcut Alt + S) the app appears to go into a mute state? (I can still hear sound in other apps okay).

Playing subsequent tracks can't be heard? Either by pressing the play button or double clicking on a track. I mouseover the volume icon and it still shows "Volume 100%". If I mouse wheel up/down over same volume icon I can hear the playing track again.

Host: PC Kernel: 5.4.0-84-generic x86_64 bits: 64 Desktop: Xfce 4.16.0 Distro: Linux Mint 20.2 Uma
rizlaw
Posts: 11
Joined: Tue Jun 11, 2019 4:05 pm

Re: Latest 09-17-21 Lauchpad build of Guayadeque for 20.04LTS broken

Post by rizlaw »

Sent you a PM with terminal output.
rizlaw
Posts: 11
Joined: Tue Jun 11, 2019 4:05 pm

Re: Latest 09-17-21 Lauchpad build of Guayadeque for 20.04LTS broken

Post by rizlaw »

Something else I've noticed since Guayadeque broke:

When the audio output device is set to ALSA, hw:X2,0 (which by the way is correct and what I have always used in all prior versions of Guayadeque), I get the error that a gstreamer plugin is missing and no playback occurs.

If I set the output device to "Automatic", everything works as it should, but I doubt that I'm getting bit perfect output since audio is most likely going through Pulse Audio.
Post Reply