Debian 10 "Buster" installation

General discussions
Post Reply
rsb2097
Posts: 1
Joined: Sun Oct 13, 2019 1:05 am

Debian 10 "Buster" installation

Post by rsb2097 »

How to download and install Guayadeque for Debian 10?

User avatar
anonbeat
Posts: 1986
Joined: Thu Sep 16, 2010 9:47 pm

Re: Debian 10 "Buster" installation

Post by anonbeat »

Debian 10 is equivalent to Ubuntu 19.04 disco. You can install the disco package

https://launchpad.net/~anonbeat/+archiv ... /+packages

pmasy
Posts: 1
Joined: Thu Feb 27, 2020 10:09 am

Re: Debian 10 "Buster" installation

Post by pmasy »

Dear developer,
I tried to install your music player on a Debian Buster installation.
I downloaded the disco package : guayadeque_0.4.6.r2124.3ef808d~disco-1_i386.deb
During the installation using apt-get install the following error occurred :

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
guayadeque : Depends: libindicate5 (>= 0.4.90) but it is not installable
E: Unable to correct problems, you have held broken packages.
Could you please let me know how to fix the issue ????

User avatar
anonbeat
Posts: 1986
Joined: Thu Sep 16, 2010 9:47 pm

Re: Debian 10 "Buster" installation

Post by anonbeat »

you must install from source code...

See the wiki at https://github.com/anonbeat/guayadeque/ ... InstallGIT

oenus
Posts: 1
Joined: Thu Jan 09, 2014 1:21 pm

Re: Debian 10 "Buster" installation

Post by oenus »

Using the PPA didn't work for me. I had to download from git and compile. However, it is quite straightforward:

Code: Select all

sudo apt-get install build-essential git libgdk-pixbuf2.0-dev libtag-extras-dev libgstreamer-plugins-base1.0-dev libgstreamer1.0-dev libwxsqlite3-3.0-dev libwxbase3.0-dev libcurl4-openssl-dev libdbus-glib-1-dev cmake

git clone https://github.com/anonbeat/guayadeque.git

./build

sudo make install
Cheers,

Ignacio

diracsbracket
Posts: 1
Joined: Sun May 31, 2020 7:31 am

Re: Debian 10 "Buster" installation

Post by diracsbracket »

Tried compiling from source in Buster.

I couldn't get wxWidgets to be detected unless I also installed (in addition to the other dependencies listed in other posts and the wiki):

Code: Select all

libwxgtk-media3.0-dev
libwxsqlite3-3.0-dev
libindicate has been obsoleted and is no longer available in the Buster rep.
- I tried to install it from the Stretch rep. (I installed both libindicate5 and libindicate-dev)
which seemed to work, as the configuration completes (and detects the package) and the build proceeds without errors.

When I launch however, I got a list of messages like:

Code: Select all

../src/common/object.cpp(251): assert "classTable->Get(m_className) == NULL" failed in Register(): Class "wxCommandEvent" already in RTTI table - have you used IMPLEMENT_DYNAMIC_CLASS() multiple times or linked some object file twice)?
...
(guayadeque:112454): Gtk-ERROR **: 03:37:07.569: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
Trace/breakpoint trap
First, I thought it was because of the Stretch version of libindicate5 and libindicate-dev I installed, so I purged those again.
These are no longer detected by the build script.

After make uninstall followed by make clean, I repeated the build (without libindicate detected), but got exactly the same messages and error as first. Running ldd on the binary, I get:

Code: Select all

user@busterPC:~/guayadeque/src$ ldd guayadeque | grep libwx
	libwx_baseu-3.0.so.0 => /lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0 (0x00007fa7643d2000)
	libwx_gtk3u_core-3.0.so.0 => /lib/x86_64-linux-gnu/libwx_gtk3u_core-3.0.so.0 (0x00007fa763d77000)
	libwx_gtk3u_adv-3.0.so.0 => /lib/x86_64-linux-gnu/libwx_gtk3u_adv-3.0.so.0 (0x00007fa763b93000)
	libwx_baseu_net-3.0.so.0 => /lib/x86_64-linux-gnu/libwx_baseu_net-3.0.so.0 (0x00007fa763b49000)
	libwx_gtk3u_html-3.0.so.0 => /lib/x86_64-linux-gnu/libwx_gtk3u_html-3.0.so.0 (0x00007fa763a6e000)
	libwx_baseu_xml-3.0.so.0 => /lib/x86_64-linux-gnu/libwx_baseu_xml-3.0.so.0 (0x00007fa763a5c000)
	libwx_gtk3u_aui-3.0.so.0 => /lib/x86_64-linux-gnu/libwx_gtk3u_aui-3.0.so.0 (0x00007fa7639c1000)
	libwx_gtk3u_qa-3.0.so.0 => /lib/x86_64-linux-gnu/libwx_gtk3u_qa-3.0.so.0 (0x00007fa76398f000)
	libwxsqlite3-3.0.so.0 => /lib/x86_64-linux-gnu/libwxsqlite3-3.0.so.0 (0x00007fa7630d9000)
	libwx_gtk2u_core-3.0.so.0 => /lib/x86_64-linux-gnu/libwx_gtk2u_core-3.0.so.0 (0x00007fa75fc4c000)
So both libwx_gtk2u_core-3.0.so.0 and libwx_gtk3u_core-3.0.so.0 are linked!?

Using dlocate, I quickly found the package that owns the gtk2u version:

Code: Select all

umagi@busterPC:~/guayadeque/src$ dlocate -S libwx_gtk2u_core-3.0.so.0
libwxgtk3.0-0v5:amd64: /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-3.0.so.0.4.0
libwxgtk3.0-0v5:amd64: /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-3.0.so.0
However, I cannot uninstall this libwxgtk3.0-0v5 package, as it is a dependency of libwxsqlite3-3.0-dev, and the build needs libwxsqlite3-3.0-dev in order for wxWidgets to be detected.

How can I get around this mess?
Last edited by diracsbracket on Sun May 31, 2020 8:25 am, edited 2 times in total.

Post Reply