'Import Files' doesn't do anything - 0.3.5
  • 0.3.5 Running under Lubuntu 12.10-64bit

    I select My Music/Import Files twice then Collection/Import Files twice.

    Terminal shows:
    12:16:46: OnCollectionCommand 13119 0 19 0
    12:17:45: OnCollectionCommand 13119 0 19 0
    12:18:54: OnCollectionCommand 13119 0 19 1
    12:19:14: OnCollectionCommand 13119 0 19 1

    But nothing happens.
    What could be the problem?
  • It should show up a dialog where you can select the tracks you want to import the copy to option to use for the import. Can you give me more details about the actions you are doing to get that problem ?

    Thanks in advance
  • No actions in particular. I tried again. Different views, songs playing, not playing. Doesn't matter. I can't ever get the dialog to show up. Don't have problems with other dialogues like 'add path'.
    I'd like to help but I don't know how give more specific info.
  • Please can you explain the steps you are doing ? There are many ways to do the same in guayadeque and maybe im doing in some other way...

    Thanks for your help
  • Alright. I do it step by step.
    1) Launch Guayadeque - greeted by album view.
    2) From the top menu I select Sources -> My Music -> Import Files...nothing.
    3) Now I right click on my album view and select Collection -> Import Files... nothing.
  • Please can you try using guayadeque-svn package from my ppa ?

    I tried the ways you mentions and it worked all
  • Oh I should mention, I get this with pretty much every X app:

    "** (guayadeque:3816): WARNING **: Invalid borders specified for theme pixmap:
    /usr/share/themes/Lubuntu-default/gtk-2.0/images/null.png,
    borders don't fit within the image

    ** (guayadeque:3816): WARNING **: Invalid borders specified for theme pixmap:
    /usr/share/themes/Lubuntu-default/gtk-2.0/images/scrollbar_vertical.png,
    borders don't fit within the image

    ** (guayadeque:3816): WARNING **: Invalid borders specified for theme pixmap:
    /usr/share/themes/Lubuntu-default/gtk-2.0/images/null.png,
    borders don't fit within the image

    ** (guayadeque:3816): WARNING **: Invalid borders specified for theme pixmap:
    /usr/share/themes/Lubuntu-default/gtk-2.0/images/scrollbar_horizontal.png,
    borders don't fit within the image
    "

    Can this be an issue?
  • That are issues with your gtk theme. I dont think it is any problem about the import dialog to show up but you can try changing to another theme.
    What version are you using ? can you try with the package I suggested ?

    Thanks for your help
  • deleted double post
  • Don't like resurrecting an old thread but I wanted to chime in as I've got the same issue as Sven: import files is doing nothing, whether through my music or collections. No dialogue box is appearing, though I do get a dialogue for add path, etc.

    I'm not getting the warning messages Sven is though I do get

    17:04:07: OnCollectionCommand 13119 0 19 0
    17:04:12: OnCollectionCommand 13119 0 19 1

    I've tried re-adding & updating
    ppa:anonbeat/guayadeque but it makes no difference.

    I've also tried
    sudo add-apt-repository ppa:anonbeat/guayadeque-svn
    but get "Cannot access PPA (https://launchpad.net/api/1.0/~anonbeat/+archive/guayadeque-svn) to get PPA information, please check your internet connection."
    so I assume I'm mistyping the proper ppa/package name.

    Any suggestions?
  • it should be
    sudo apt-get remove guayadeque
    sudo add-apt-repository ppa:anonbeat/guayadeque
    sudo apt-get update
    sudo apt-get install guayadeque-svn

  • That's mostly worked, but not all the way - I now get the dialogue box but I find that when I add files to the box the ok button remains greyed out so I still can't import.
  • When trying to import files via terminal I get the messages:

    23:19:22: StatusChanged( 1, 0, 0, 0 )
    23:20:41: OnCollectionCommand 13119 0 19 0
    TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
    TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
    TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
    TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
    TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
    TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
    TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
    TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.
    TagLib: ID3v2.4 no longer supports the frame type TDAT. It will be discarded from the tag.

    still no option to click ok.
  • You must select the copy to option or add a new one. After that if there have been added files to import the accept button should be enabled.
  • That's great anonbeat, thanks. Guess I'm still getting used to guayadeque so I didn't think to need to select default as the copy to option as it was already displayed.
    It's importing fine now,

    Thanks
  • Hello,
    I have the same problem under Ubuntu 12.04 LTS desktop freshly installed.

    Once installed Guayadeque through Ubuntu Software Center I tried to import files, but nothing happens. No dialogue box appears.
    Both the following actions do not work:

    Sources --> My Music --> Import Files
    Right click of the mouse from 'Library view' of 'My Music' tab --> Collection --> Import Files

    I do not receive any warning though.
    What am I supposed to do? Shall I remove Guayadeque with Ubuntu Software Center and reinstall it with apt-get as anonbeat suggests? Or 'apt-get remove' does the same job?

    Are the following commands still valid?

    sudo add-apt-repository ppa:anonbeat/guayadeque
    sudo apt-get update
    sudo apt-get install guayadeque-svn

    Will Ubuntu Software Center be updated after completion of the installation with apt-get?
  • You must add library paths to the default collection. Once you are set you can import music to the collection I bet what you are trying to do is let it scan your music collection so once you added the paths to the collection called "My Music" you can do a rescan on the collection to let it scan all the music files under the paths you selected.

    Thanks for your help
  • Thanks anonbeat,
    this is exactly what I wanted to do :)

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with OpenID

In this Discussion