Installation 18.04
  • Hi,

    I am trying Xubuntu 18.04 Daily in a virtual machine (Boxes)

    I can't install Guayadeque as I used to:

    sudo apt install git build-essential cmake gettext
    sudo apt install libwxgtk3.0-dev libtag1-dev libwxsqlite3-3.0-dev libsqlite3-dev
    sudo apt install libcurl4-gnutls-dev libdbus-1-dev libgstreamer1.0-dev libgpod-dev libindicate-dev
    sudo apt install libgstreamer-plugins-base1.0-dev
    cd /opt
    sudo git clone https://github.com/anonbeat/guayadeque.git
    cd guayadeque
    sudo ./build
    sudo make install

    After sudo ./build I get and ERROR, 'wxWidgets not found!'

    Any ideas please?
  • well, try installing wxWidgets......
    I'm not on ubuntu anymore so I don't know it it's in the repo but google a bit.
    ...or wxgtk2 or wxgtk3
  • I tried to install WxWidgets , wxgtk2 and wxgtk3 without success (not found)

    Then I tried to repeat installing all the dependencies as listed above (since I had used autoremove in the meantime and thought maybe some had been uninstalled).

    However I noticed an error about installing cmake about libcurl4 (not sure if this was there before)

    So I installed libcurl4

    After this the sudo ./build and sudo make install worked and now I have Guayadeque on Xubuntu 18.04 :)

    Obviously, I am still not very good at building from source :)
  • Using it on 18.04 without problems.
  • Well not in virtual machine
  • Me too now
    I just use the ppa
    Still love it :)
  • for me, it doesn't work after arch switched to gnome 3.30 :(
    again something related to wxwidgets

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with OpenID

In this Discussion